libmagic dev files

Our puppies are built with the 'file' package, which has 'libmagic' library, but the development components are left out of the 'devx' sfs. That is, there is no libmagic.so or magic.h.

I can't recall if there was any reason for that.

I am messing around with compiling the 'rpm' package, and it complained about the missing dev files for libmagic, which brought my attention to it.

For Wary I have created 'file_DEV' PET package, for the purpose of compiling rpm.

I have also modified the build rules for all other puppies in Woof so that the dev files for the 'file' package will be built into the 'devx' sfs.


Posted on 5 Nov 2010, 18:13


No comments posted yet.