Video Upgrade Wizard enhanced

I have done a couple of important things:

1. Generalised for other than Wary
In the current release of Woof, if you build any Puppy other than Wary, trying to run the Video Upgrade Wizard (Setup menu, or 'setup' icon on desktop) pops up a message that it only runs in Wary.
I have now generalise the scripts so it will work in other builds. Potentially anyway -- developers, you will need to examine the scripts in /usr/local/video_upgrade/ to see the requirements. Mostly, it means you would have to upload nVidia, and ATI PET packages with certain naming convention.

2. ATI commercial drivers supported
I have added support for ATI commercial drivers. So far I only have one PET package, that I created for Wary and the 2.6.31.14 kernel.
What should happen now, when you run the Wizard, it will determine if the available ATI drivers are suitable for your video card and if so offer to install it.


Posted on 6 Nov 2010, 8:45


No comments posted yet.