Frugal install bug fix

The Universal Installer, script /usr/sbin/puppyinstaller, gives wrong information when doing a frugal installation.

It states that you can only install one-deep, say in folder /wary094, however you can install as deep as you want, say /puppyfiles/wary/wary094.

However, if Puppy is not provided with a PSUBDIR boot parameter, the 'init' script only searches 2-deep (falling back to 3-deep if cannot find the files, but that slows bootup as is to be avoided) if no PSUBDIR is provided, so I have changed the appropriate dialog for frugal installation to advise of this and to handle appropriately -- to install 1-deep or 2-deep.


Posted on 7 Nov 2010, 7:45


No comments posted yet.