pcre, glib

I am fixing something that may not have anything to do with the recently discovered crashes of Gimp and NicoEdit, but you never know.

The 'pcre' package was compiled in T2 with the '--enable-utf8' configure option, however I discovered sometime ago that the configure script in the 'glib' package reports that does not provide unicode support and refuses to use the pcre library.

Back when I first discovered that (early Quirky), I recompiled pcre with this extra option: '--enable-unicode-properties' and then glib was happy. Here is the complete configure:

# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --enable-utf8 --enable-unicode-properties

So, I have done this again. I have recompiled pcre 8.0 and uploaded the PETs:

http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/pcre-8.00-1-w5.pet
http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/pcre_DEV-8.00-1-w5.pet
http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/pcre_DOC-8.00-1-w5.pet

I have recompiled glib 2.24.2:

# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --disable-selinux --disable-fam --with-pcre=system

Here are the PETs:

http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/glib-2.24.2-1-w5.pet
http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/glib_DEV-2.24.2-1-w5.pet
http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/glib_DOC-2.24.2-1-w5.pet
http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/glib_NLS-2.24.2-1-w5.pet


Posted on 9 Nov 2010, 19:55


Comments:

Posted on 9 Nov 2010, 21:09 by ttuuxxx
pcre, glib
Hi Barry I also started fresh earlier today and only compiled pcre-8.10, glib-2.24.2 and then rebooted clean, test nicoedit first to make sure it crashes, then Install just the 2 pets, no dev's. And nicoedit worked, I compiled it similar to your code but enabled 2 extra's configs in pcre
--enable-pcregrep-libz link pcregrep with libz to handle .gz files
--enable-pcregrep-libbz2 link pcregrep with libbz2 to handle .bz2 files
So nicoedit works out of the box, but when I ran it in the terminal it gave me this error
(nicoedit:26179): GtkSourceView-CRITICAL **: gtk_source_language_manager_get_language: assertion `id != NULL' failed

does this happen with your packages? maybe gtksourceview might need fixing also.
ttuuxxx


Posted on 9 Nov 2010, 22:04 by ttuuxxx
gettext and gtksourceview
Well I compiled the latest gettext and gtksourceview to see if that would fix the error and its still there. Well that's it for tonight, maybe Its gtk2, T2 has some patches.http://t2-project.org/packages/gtk+.html
ttuuxxx


Posted on 11 Nov 2010, 11:10 by BarryK
pcre, glib reverted
I have reverted these, as it doesn't fix Gimp.



Posted on 11 Nov 2010, 11:15 by ttuuxxx
pcre, glib reverted
Hi Barry if you manually add this patch to gimp sources it will work fine, The package I compiled used it and it doesn't crash even with the older glib compile in Wary doesn't crash it.
https://bugzilla.gnome.org/attachment.cgi?id=172474
ttuuxxx


Posted on 11 Nov 2010, 19:03 by BarryK
pcre, glib un-reverted
Sometimes what we are doing is a real balancing act.

I have just tested a pristine 096 with the new NicoEdit 2.5.3 -- and guess what, it crashes at File -> Open, both with and without utf8 locale!

I had previously compiled it with the updated glib/pcre. So, I recompiled in the Wary 096 (without the updated glib/pcre) -- it still crashes.

Hmmm.

I don't know. Anyway, I have taken the easy way out and restored the updated glib/pcre, as announced at start of this thread.



Posted on 11 Nov 2010, 23:51 by hi
hi
fwiw:
just installed the 2.5.3 of nicoedit only, and it then crashed
then the updated pcre, still crashed
then the updated glib, no crash.

Previously had utf8 and original nicoedit.
Now with utf8 and new nicoedit.




Posted on 20 Dec 2010, 12:57 by ttuuxxx
glib-atomic
Hi Barry I was building a new backend for 4.3 and well the latest glib produces an error about gatomic, I managed to find a patch, it was like looking for a needle in hay stack. so here's the patch for safe keeping
ttuuxxx
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=35915



Posted on 20 Dec 2010, 18:13 by BarryK
Re glib patch
ttuuxxx,
Thanks, I have downloaded it.