Qt4 PET smaller

I have made the Qt4 PET package much smaller, down from 17MB to 8.9MB. This was done by moving un-needed files to the qt4_DEV PET package.

Download (8.9MB):
http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/qt4-4.5.3-1-w5.pet


Posted on 9 Jan 2011, 10:23


Comments:

Posted on 9 Jan 2011, 11:29 by BarryK
Qt4 PET modified
ttuuxxx posted about the 'qtconfig' utility, to set the fonts (and other things, such as theme). So, I have put that back into the PET and created a menu entry for qtconfig, and re-uploaded the PET.



Posted on 10 Jan 2011, 19:23 by Terryphi
Is QT4 PET compatible with Quirky 130/Lupu 520?
Useful PET. Thanks! Is it compatible with Quirky 130 and/or Lupu500?


Posted on 10 Jan 2011, 19:42 by ttuuxxx
Re. Is QT4 PET compatible with Quirky 130/Lupu 520?
I would say very possible for compiling apps, some apps should work across the board, I compiled this static wysiwyg qt editor in 2.14X and its worked on puppy 5, Wary, and puppy 4.3. But it was statically built. But some things like VLC might not work on puppy 520 because it doesn't have xcb, not that I could see anyways last time I used it. But Quirky and Wary are kiss'n cousins and VLC might work, its really Just the deps that matter the most. Probably best to just try it out, I'm sure you could get QT from the ubuntu repo for 520, really what Wary needs is QT 4.7, and dbus as default, Around 15% of the QT4 apps fail because no dbus or Qt 4.6+.
I must of compiled around 30+ in past couple of days, I only uploaded what on the Wary 5.0 bugs page apps that were worth trying and ones that would compile properly.
ttuuxxx



Posted on 26 Jan 2011, 11:08 by ttuuxxx
Qt Wary
Hi Barry, now that you've made a reduce Qt version, I'm just wondering maybe you might consider building Wary with a even smaller Qt backend, well when I was messing around with Qt in 2.14X I noticed that some apps would only need one or two if the QT libs to actually make applications work, When I look at the min python in Puppy that doesn't seam to run anything and when I compile sometimes I get the missing python.so and have to disable it anyways. Perl on the other hand is another, Sometimes most the I see apps that state to run them, type "perl app-name" when I type that in, I always 100% of the time get an error in around line 30, Personally I would toss Gnome and perl out of puppy and go the either Qt or a fuller Python.

Qt has many apps and even a Qparted, Partition editor http://qtparted.sourceforge.net/
and when you add that with VLC you have a nice start, Qt apps are usually really small, there are about 7 or so QT browsers now, http://qt-apps.org/ is a great spot for qt apps that I use.
GTK-Apps http://gtk-apps.org/ is just a waste of time, around 90% of the apps use python and don't even say so in the descriptions. Really I think GTK-Apps should be renmaed to Python-Apps.
If you were to go with a QT model, I would be more than willing to compile a lot of apps. Personally I think that the latest QT should be compiled first, being that the newer qt is needed for a few of them, like you experienced with scribus.

Well Its an Idea. there's even a Qt Window manager, I used it for a couple of days and worked ok, http://qt-apps.org/content/show.php/Egg+Window+Manager?content=136862
it takes low resources also, here's a browser than needs the latest qt 4.7 http://code.google.com/p/arora/
ttuuxxx


Posted on 26 Jan 2011, 14:51 by BarryK
Re Perl in Puppy
ttuuxxx,
We can't take out Perl, it is used by a few needed things, such as ndiswrapper.

Sometime ago, I did think about a Qt-based Puppy, but I seem to remember at the time I wasn't happy with what apps were available.

ROX-Filer is pretty ingrained into Puppy, difficult to take it out, although some guys have done it.

A Puppy with Python-GTK included would be interesting, although I won't do that myself as I have a bit of a "chip on the shoulder" about the proliferation of Python.

Arora will compile with the Qt already used in Wary, as Wary's Qt has WebKit builtin. What is missing is support for https:// which needs gnutls -- I would have had to install gnutls before compiling Qt.
I have already compiled Arora, was thinking of making it into a PET.