vlc-gtk media player 2.2.1

Forum member sc0ttman developed vlc-gtk, a very small GUI frontend for the VLC media player. This provides a much smaller alternative to the Qt4 frontend provided in the VLC package and we are able to create a small vlc_nogui package that is VLC without the Qt4 GUI component.
I already posted about this:

I have fixed vlc-gtk 2.2 so that it works in Wary and also made some improvements, and bumped the version to 2.2.1. I edited both scripts /usr/bin/vlc-gtk and /usr/bin/vlc-gtk-btns.

You need to install the dependencies xcb-util, vlc_nogui and xdotool:

xcb-util (35KB):

vlc_nogui (1.7MB):

xdotool (simulate input and control windows)(38KB):

Then sc0ttman's excellent super-tiny GUI (13KB):

Posted on 10 Jan 2011, 10:33


Posted on 10 Jan 2011, 13:13 by ttuuxxx
Hi Barry when I compiled VLC I made xcb-util static, makes ones less dep and doesn't really add anything to vlc :)

Posted on 10 Jan 2011, 15:50 by BarryK
Re xcb-util
It might not be a problem, but I was concerned that Wary has the 'libxcb' package version 1.0. Other recent puppies have a later libxcb, which has API differences.

So, I thought that I might have to use an upgraded xcb-util compiled against a later libxcb.

I don't know, I was probably just being overly concerned. The thing to do it, install my 'zzx_upgrade_73_to_75_nokmx' Xorg upgrade PET, then see if vlc still works -- if so, all is fine (that upgrade PET also has a later libxcb).

P.S. I used xcb-util 0.3.4 as that is the lowest version that vlc will accept, and it is the last version usable with libxcb 1.0.

Posted on 10 Jan 2011, 16:02 by ttuuxxx
Re:RE xcb-util
Hi Barry, This the fully static xcb-util I used for compiling VLC


Posted on 10 Jan 2011, 24:07 by Terryphi
Audio volume control does not work
Audi volume does not work for me if volume is changed from default level 3.