usb-modeswitch 1.1.7

I have upgraded to usb-modeswitch 1.1.7, for all Woof-built puppies. Also Jimtcl is upgraded to 0.70. The packages are:

jimtcl-0.70.pet
usb-modeswitch-1.1.7-patched.pet
usb-modeswitch-data-20110227.pet


It is a bit premature to install these in any Puppy now though, as I also modified some scripts in Woof to work properly with them -- so you need to wait for the next Woof, or the next Puppy built from the next Woof.

While I was at it, I fixed a shortcoming when a 3G modem is plugged in at bootup -- it didn't always get configured properly, compared with plugging it in after bootup. Now, you get the popup message that the 3G modem is ready for use in both cases.

I have only tested so far with my most difficult 3G modem, model K3571 Z.


Posted on 2 Mar 2011, 23:21


Comments:

Posted on 3 Mar 2011, 6:16 by bigpup
upgrading Puppy
Barry,
You may want to check out the Luci 252 topic in the forum in a few days. One of the things that is being heavily tested is how well Puppy will upgrade, from the last version to the next.
I had problems upgrading a full install.
http://www.murga-linux.com/puppy/viewtopic.php?t=65136&start=150


Posted on 3 Mar 2011, 6:20 by bigpup
upgrading Puppy
My upgrade post:
http://www.murga-linux.com/puppy/viewtopic.php?p=500195#500195