BaCon compiler 1.0.21

Wary 5.1.x has BaCon "1.0.21pre" in the devx sfs, which was announced here:

I have upgraded to 1.0.21 (670KB):

There are significant enhancements, especially closer Qbasic syntax support and internationalisation support:

BaCon was compiled in Wary, however the PET will work in all puppies.

Posted on 5 Mar 2011, 18:17


Posted on 6 Mar 2011, 19:30 by L18L
Hi Barry,
as internationalisation is the right step to be done before localisation, I am thinking you can count on help from me (and others I'm sure) if you like to accept.
discovered this site at the moment well worth to dig in.

Posted on 7 Mar 2011, 17:43 by BarryK
BaCon PET re-uploaded
I have re-uploaded the PET, as a bug was discovered with the 'fetch' utility that is included in the package.

This was discussed on the BaCon forum:

Note that 'fetch' is also included in Woof, in the 'support' directory.

Posted on 8 Mar 2011, 17:58 by BarryK
HUG fix
I have added the fixed hug.bac, for internationalisation support, see blog post:

The BaCon PET has been re-uploaded.