Quirky: new packages

I have compiled these packages in Quirky:

glib12 1.2.10
gtk+12 1.2.10
imlib 1.9.15
gdk-pixbuf0 0.22.0
rox_filer_gtk1 1.2.2-patches_12_root
flashplayer9_pretend10
seamonkey_nomail 2.0.13


Rox-Filer has the latest patches from argolance plus running-as-root patch. The Flash Player has technosaurus's patch.

I have compiled SeaMonkey without the mail&news module to make it smaller.

These PETs will be usable in the upcoming Quirky 1.5 and also in Wary.

They are uploaded here:
http://distro.ibiblio.org/quirky/pet_packages-quirky/


Posted on 27 Mar 2011, 22:34


Comments:

Posted on 27 Mar 2011, 22:40 by BarryK
Not gtk 1.2
Just a note so that other developer guys know... I do not plan to create a baby Linux based on GTK 1.2 apps -- I reckon that goingnuts and technosaurus are doing a great job in that direction and I won't compete.

However, I thought that I would make the GTK 1.2 PETs available for Quirky/Wary in case anyone wants to run any of the old GTK 1.2 apps.

I am staying with GTK 2.x for the next Quirky, and just going through very carefully to eliminate fat, also looking at some ideas in that direction.



Posted on 28 Mar 2011, 8:37 by BarryK
Sylpheed 3.1.0
I have compiled Sylpheed mail and news for Quirky:

http://distro.ibiblio.org/quirky/pet_packages-quirky/



Posted on 30 Mar 2011, 2:13 by ttuuxxx
new packages
Hi Barry I'm not running quirky right now, I did come across a A GTK Based Strategy Game that's pretty good, the pet size for 2.14X is 28kb
I altered the sources, because the .desktop was going into a games folder, so now it goes to the applications folder like it should.
Then I compressed and changed a few of the images to better looking ones a saving of 180kb.
here's the sources http://murga-linux.com/puppy/viewtopic.php?mode=attach&id=39388
and If you wanted to try the compiled 2.14X version, It should work on Wary/quirky anyways since 2.14x has the same glibC, gcc and a few other libs same as Wary, I've been bridging the gap on 2.14X/Wary my next couple of release will go a bit further, like jpg/sqlite/libpoppler.
Its truly amazing that 2.14X is still booting after so much of it being updated.
http://murga-linux.com/puppy/viewtopic.php?mode=attach&id=39389 <-- the game pet for 2.14X