Linux headers 2.6.32.38

I thought that I would throw this out here, before doing it, in case someone knows a reason why I shouldn't do it.

The T2 packages compiled for Wary used Linux headers 2.6.27.

However, it is likely that the 2.6.32 kernel will soon be the lowest version that has long-term support, also it is the highest version on which I am able to compile my complete collection of analog modem drivers.
Personally, I have not encountered any hardware that does not like the 2.6.32.x kernel. There were some reports about PCMCIA cards not working, that worked with an older kernel, but I haven't had any problem with PCMCIA myself.

So, I am thinking of not using any kernel below 2.6.32 for Wary.

The next build of Wary will have my Linux headers 2.6.32.38 PET package in the 'devx', but I am also thinking of recompiling gcc and glibc against these headers. No version upgrade of gcc/glibc, only a recompile.


Posted on 17 Apr 2011, 9:26


Comments:

Posted on 17 Apr 2011, 10:25 by scsijon
headers change
I did notice with woof that some of the packages and libs used in lucid have kernal information in their name, although they seemed to work ok with the other kernals I tried.
I take it you don't have the same build requirements with wary?