SM 1.1.18 plus addons

I have built an experimental Wary with SeaMonkey 1.1.18 that I compiled back in the early days of Quirky, and I have created a nice selection of addons for it. I did the build in Woof with these all built-in:

adblock 0.5.3-43
fullerscreen 2.3.3
zombiekeys 1.1.4
user agent switcher 0.7.2
copy plain text 0.3.3
flashblock 1.3.17


This SM is the full suite, but small, the PET is only 9.1MB, and those addons are very small. Adblock is considerably smaller than AdblockPlus.

Remember Fullerscreen? It fills a gap in Puppy, a presentation application. It's an SM addon that runs standalone, in the Graphic menu.

This is a great combo for those on dialup, and older computers, good choice for Wary I think.
I'm using it now, running off a Flash pen drive.

Note, those addons are uploaded, look for seamonkey1_addon*.pet here:
http://distro.ibiblio.org/quirky/pet_packages-wary5/

And seamonkey1-1.1.18*.pet is here:
http://distro.ibiblio.org/quirky/pet_packages-quirky/

The addons are intended to be chosen in Woof when building a Puppy, I haven't tested them if installed afterward.


Posted on 27 Apr 2011, 2:13


Comments:

Posted on 27 Apr 2011, 10:06 by wuxiandianzi
woof script failed to build from archlinux
Hi baryyk
yesterday I tried to build a new puppy based on the packages of archlinux in woof.
The frist step "#./0setup" runs well with archlinux dependencies。
but the second step "#./1download" failed because the url in DISTRO_PKGS_SPECS-arch does not exist。So I added “http://mirrors.sohu.com/archlinux/” anddownloaded all the packages from it.
it about 600M.
The third step"# ./2createpackages" failed showed that something wrong with gzip command“... not gzip format” “...mv wrong”
you know that packages of archlinux is *.xz format. I unpacked all the packages and Compressed them with “*.tar.gz” by manual。
It still failed to go on. I do not know why.
I did this in puppy-4.31 and I install the xz soft compiled by myself.


Posted on 27 Apr 2011, 10:13 by wuxiandianzi
woof script failed to build from archlinux
puppy-4.31 was full installed by ext3 format on disk with 80G free space.
I successed building a puppy based on puppy +t2+xorg7.3.


Posted on 28 Apr 2011, 11:10 by playdayz
Puppy Browser
With SM 1.1.18 you can again offer PuppyBrowser. We have had several people request it, so that there is a version in circulation, and it is still a hit!


Posted on 28 Apr 2011, 12:59 by DaveS
Google Docs
Unable to get Google Docs spreadsheet to display in SM 1.1.18


Posted on 28 Apr 2011, 13:25 by Dewbie
PuppyBrowser
Regarding playdayz' comment, if PuppyBrowser is ever reintroduced, it would be wise to test-install later versions of SeaMonkey to see if they break PuppyBrowser. This was an issue with Puppy Linux 4.3.1. Thanks.


Posted on 28 Apr 2011, 18:49 by BarryK
Re PuppyBrowser
That would be what we also called Gtkmoz.

Yes SM 1.1 and earlier have libgtkmozembed.so that supports these light-weight browsers. Though, I don't have it in my 1.1.18 PET as I trimmed that right down.

So for Wary I am using Surfer for the internal HTML viewer, which uses libgtkhtml. Libgtkhtml is also used by Osmo. It is a simple viewer, with some CSS support, but not quite good enough for the CUPS web interface.

Actually, that would be an interesting project for someone, see if they can simplify the CUPS web interface to work with Surfer (the executable is 'surfer') and libgtkhtml.

One thing that is going to be interesting, Firefox 4 has reintroduced a library that will make light-weight browsers feasible again, plus WYSIWYG web page editing, just like Composer -- there is already such a project for FF4, can't recall it's name.



Posted on 29 Apr 2011, 7:54 by ozsouth
FF4 with Simplemail?
I noticed that the 'simplemail' Ffox plugin is again active. I set up v2.79 with Ffox 3.6.13 in 'Mywolfe 028' puplet yesterday & it works OK, even with 2 accts. (There were also issues with some attachments in v2.74). If Ffox 4 has a 'Composer' it appears our full requirements are met.


Posted on 29 Apr 2011, 10:08 by scsijon
sm1 blocked
A lot of the business sites I use give a warning with sm1 that they don't support it and you need to upgrade to at least sm2 to access.

hope it doesn't become a blocker

regards


Posted on 8 May 2011, 13:54 by DMcCunney
SeaMonkey suggestions
Hi, Barry:

It's nice to have a newer SeaMonkey, but I suggest you compile the most recent SM 1.1 version, which is 1.19. That's an "end-of-life" release, which will be the last 1.1 branch release. No one was contributing patches, and the engineer providing the Mozilla builds was hosting the servers in his cellar, and wanted to turn them off.

You might want to look at http://www.lamarelle.org/mo-zi-lla/mozilla.php#smf

Phillipe-Pierre has done static Gtk1 and Gtk2 builds of the full SeaMonkey 1.19 suite. His bz2 file for the Gtk2 build is about 10MB. I posted pointers to them on the Puppy forums months back, and Phillipe indicated a lot of folks grabbed them.

And if you are concerned about conserving space, I'll make a suggestion: include no addons.

By default SeaMonkey ships with Chatzilla, the DOM Inspector, and the JavaScript debugger, which install in the application directory. Omit them. Few end users use the DOM Inspector or the JavaScript Debugger, and they aren't shipped with Firefox. Don't include them.

Don't install any of your own choices, either. People who want extensions can download and install the ones they want from the Mozilla Addons site. There is no need to include them with or package them for Puppy. And building them in is a problem, because SeaMonkey 1.1 provides no built in way to remove them if you don't want them. To remove unwanted extensions, you must install the Extension Uninstaller or the Mnenhy packages. If you insist on including addons in your SeaMonkey build, at least add one of them so people have the option of removing your additions.



Posted on 17 May 2011, 4:29 by misha
addons
I've got SM1.18 running and have tried to install an addon from the mozilla website and failed. My question is, is it possible to install any of these add ons with SM 1.18 (puppy 5.1.1.56)?


Posted on 17 May 2011, 20:16 by BarryK
Re sm 1.1.x addons
You need addons specifically for SM 1.1, such as at site seamonkey.be



Posted on 17 May 2011, 21:25 by f00-
even then..
Make sure you can return to a previous state - I once installed multiviews-v1834.xpi (a remake of MultiZilla for sm) and never did get completely rid of it, even with some quality time spent in Mnenhy. It (multiviews) seemed like a good idea at the time.. but trying to uninstall it was a lesson learned.


Posted on 19 May 2011, 17:05 by phoolish1
sm 1.18
Hi I would like to ask the whereabouts of the addon manager in seamonkey 1.18, if any? I installed a couple from the mozilla website but now I need to uninstall one, how can this be performed?


Posted on 19 May 2011, 17:59 by BarryK
Re SM uninstall addons
That is a problem with the SM 1.x series, no addon manager. Uninstalls have to be done manually -- usually they will be installed into /root/.mozilla and you just delete new files, though sometimes other files get modified which complicates the uninstall.

Alternatively, you can wipe all of your addons and get back to the original, if not running a full HD installation -- look in /initrd/pup_rw and delete everything that looks like a SM addon file. Look especially in /initrd/pup_rw/root/.mozilla, but some addons install into /initrd/usr/lib/seamonkey. Do this without SM running. You may need to reboot for the deletions to be properly recognised.



Posted on 12 Jun 2011, 6:46 by broomdodger
SeaMonkey 1.1.8 plugin crash
SeaMonkey 2.1 announced today

"Plugin crashes do not take down the whole application anymore since plugins run in their own processes now."

SeaMonkey 1.1.8

Seems solid unless I try to watch some videos, mostly movie trailers. I have plenty VM and SeaMonkey does not seem to use it.

It seems more like a plugin. mplayer?
Any ideas? suggestions? fixes?



Posted on 13 Jun 2011, 3:26 by hoof
SM1.1.18-java
I can't get SM1.1.18 to recognize the java plugin libjavaplugin_oji.so in the /usr/lib/mozilla/plugins folder. Java is eneabled under preferences and it shows the plugin at about:plugins, do I need an old java version to be compatible?