rpm 4.8.1

I have compiled the 'rpm' package in Wary, with Mageia 1 patches.

I had to upgrade popt, and the Berkeley database is a dependency (24KB, 70KB, 386KB, 683KB):
http://distro.ibiblio.org/quirky/pet_packages-wary5/popt-1.16-w5.pet
http://distro.ibiblio.org/quirky/pet_packages-wary5/popt_DEV-1.16-w5.pet
http://distro.ibiblio.org/quirky/pet_packages-wary5/db-4.8.26-w5.pet
http://distro.ibiblio.org/quirky/pet_packages-wary5/db_DEV-4.8.26-w5.pet

Note that Wary does not have the Berkeley database package builtin. Many other puppies do, but Wary doesn't have any packages that need it, at least none of the builtin ones.

The rpm PET (447KB, 65KB, 72KB, 411KB):
http://distro.ibiblio.org/quirky/pet_packages-wary5/rpm-4.8.1-patched_mageia1-w5.pet
http://distro.ibiblio.org/quirky/pet_packages-wary5/rpm_DEV-4.8.1-patched_mageia1-w5.pet
http://distro.ibiblio.org/quirky/pet_packages-wary5/rpm_DOC-4.8.1-patched_mageia1-w5.pet
http://distro.ibiblio.org/quirky/pet_packages-wary5/rpm_NLS-4.8.1-patched_mageia1-w5.pet

Thanks to 01micko for advice on how to compile the rpm package.


Posted on 19 Jun 2011, 23:29


Comments:

Posted on 19 Jun 2011, 23:44 by BarryK
rpm source
The source is the SRPM from the Mageia 1 repository. I have uploaded the patched source, as 'rpm-4.8.1-patched_mageia1.tar.gz' here:

http://bkhome.org/sources/alphabetical/r/
(usual login)



Posted on 20 Jun 2011, 9:52 by BarryK
rpm mime handling
I created a RPM icon for ROX-Filer. This is in Woof, so will be present regardless of what ROX package Puppy is built with.

I have changed /usr/local/bin/pupzip so that it uses 'exploderpm' instead of 'rpm2cpio'. Hopefully this will expand all RPMs, not just those from Mageia.

Note that pupzip is not handling RPMs in the most efficient manner, as exploderpm is being used to expand the RPM and convert to a .tar file, then open in Xarchive (or Xarchiver). So, there is an intermediary expansion in /tmp.