Urxvtset 0.5

Forum member stu90 has created a great little GUI utility to configure the appearance of urxvt (rxvt-unicode), the terminal emulator (window) used in most of our puppies these days.

Here is the forum thread:
http://www.murga-linux.com/puppy/viewtopic.php?t=68624

I have repackaged it slightly and uploaded the PET to ibiblio.org, the 'common' repo.

I changed the 'urxvtset' executable location to /usr/sbin, modified /root/.Xdefaults, some changes in /usr/share/applications/urxvtset.desktop and pet.specs.

urxvtset-0.5|urxvtset|0.5||Desktop|44K||urxvtset-0.5.pet|+yad,+urxvt|UrxvtSet setup terminal emulator||||

A great little app, stu90 is doing a lot of work developing applets using yad.

Here it is (3KB):
http://distro.ibiblio.org/quirky/pet_packages-common/urxvtset-0.5.pet

I have entered this into the PKGS_SPECS_TABLE variable of all the builds in Woof.


Posted on 4 Aug 2011, 8:24


Comments:

Posted on 4 Aug 2011, 14:46 by broomdodger
screen missing libshadow.so.0
downloaded screen-4.0.3-w5 from ppm

233724 which screen
/usr/bin/screen

233728 screen --help
screen: error while loading shared libraries: libshadow.so.0: cannot open shared object file: No such file or directory



Posted on 4 Aug 2011, 18:10 by BarryK
screen?
broomdodger,
What Puppy are you using? Your report is meaningless without that info.



Posted on 4 Aug 2011, 18:12 by BarryK
No scrollbar
I have just realised that the scrollbar has disappeared after running Urxvtset.

I will have to fix that and repackage the PET.

Anyone know why?


Posted on 4 Aug 2011, 19:49 by BarryK
Urxvtset scrollbar
Ok, I edited /root/.Xdefaults in the Urxvtset package to restore the scrollbar. I have re-uploaded the PET.



Posted on 4 Aug 2011, 20:06 by L18L
no yad on puppy 431
just a reminder:
yad is not running on puppy 431

yad: /lib/libc.so.6: version `GLIBC_2.7' not found (required by yad)
#Exiting


A fix would be nice to have
My regards


Posted on 4 Aug 2011, 21:04 by BarryK
Re no yad
I am not supporting 431 anymore. I am treating Wary as the base (lowest-level) system.

However, if you look at stu90's forum posts for SimpleWALL and SimpleGTK, I think there is a yad PET.



Posted on 4 Aug 2011, 23:14 by broomdodger
re screen?
wary 512 + devx


Posted on 5 Aug 2011, 7:53 by BarryK
'shadow' needed by 'screen'
broomdodger,
Would you mind conducting an experiment -- in PPM, puppy-wary5 repo, you will find the 'shadow' package -- install that, then test screen.

Let me know if it works, but also let me know if 'shadow' does not not interfere with normal Puppy startup and shutdown -- try a reboot.

Thanks.



Posted on 5 Aug 2011, 8:57 by broomdodger
re: 'shadow' needed by 'screen'
Barry,
Installed shadow, then "screen --help" worked.
At this point, all I know what to do with screen.

I installed screen because I wanted to learn to use it.
I was given an example, but have not explored.

Reboot worked ok.

Thank you.
Now, that is... when time permits, I will learn to use screen.



Posted on 5 Aug 2011, 9:19 by BarryK
Updated Screen PET
Thanks for the feedback, I have added +shadow dependency in pet.specs in the screen PET. Will upload to wary5 repo soon.



Posted on 5 Aug 2011, 16:15 by L18L
Re Re no yad
Sorry, I had forgotten 431 is recent no more.

So, I have compiled Yad and put the PET into the 'common' repo. I added 'yad' to the package choices for Wary, Spup, Dpup, etc. in Woof.


'common' repo is confusing as it is accessible from 431 and let yad be installed but not run.
The check "`which yad`" would not be sufficient in this case.

Maybe adding a dependency (which one is beyond my scope) can avoid some frustrations.

Best regards from a yad fan





Posted on 5 Aug 2011, 17:17 by BarryK
Not confusing
The PPM in 431 does not offer the 'common' repo, so there is no confusion.

PETs in the official repos should be accessed via the PPM, not by browsing ibiblio.org.

My posts in this blog with direct links to PETs are for developers/testers running Wary/Lucid/Dpup/etc, any fifth-generation puppy.