2.6.32-44 Linux kernel

I have compiled the latest in the 2.6.32 series.

The kernel PET (for Woof developers only) (29.1MB):
http://distro.ibiblio.org/quirky/pet_packages-common/linux_kernel-2.6.32-44-i486-w5.pet

Sources:
http://bkhome.org/sources/kernel-2.6.32-44/

Wary 5.1.2 has kernel 2.6.32-40 and this is built in such a way that it identifies itself as version 2.6.32 and the modules are in /lib/modules/2.6.32. This latest, 2.6.32-44, has also been configured like this so identifies itself as 2.6.32.

The above potentially causes a problem when upgrading a pupsave file. Upgrading from 2.6.32-40 to 2.6.32-44 is not intended to be any problem, however I have configured the latter with inbuilt HID and USB drivers, which may make other modules incompatible. In other words, if you had compiled or installed a module compiled for the 2.6.32-40 kernel, it might not work with the 2.6.32-44 kernel, or it might. In future, I will keep the same configuration, so older modules will continue to work when the kernel is upgraded (to 2.6.32-45 etc).

I have edited the 'init' script in the initrd, and /etc/rc.d/rc.update to take care of some possible old incompatible modules when there is an upgrade of a pupsave, as described in previous paragraph.


Posted on 11 Aug 2011, 19:04


No comments posted yet.