Lucid Puppy 5.2.8 released

Lucid Puppy is our "flavour" or edition of Puppy Linux that is built from Ubuntu binary packages, hence has compatibility with, and access to, the vast Ubuntu package repositories.

Coordinator "playdayz" (Larry Short) has made this short announcement:

Lucid Puppy 5.2.8 is the fastest and friendliest Lucid yet. It is the fastest because it is the first Lucid to use the C and ffmpeg libraries optimized for i686 computers rather than the older i386 computers. Lucid 5.2.8 has also received a thorough going-over under the hood. There is new and updated firmware and drivers for many devices, courtesy of forum member tempestuous, and the hardware detection and configuration routines have been extensively tested and enhanced by forum member rerwin. The overall look and feel has been influenced by experiments forum member pemasu, to make the user interface fun for Linux newbies and experienced users alike.

For a longer announcement and release notes:
http://distro.ibiblio.org/puppylinux/puppy-5.2.8/release-Lucid-528.htm

Download the live-CD iso file (129.2MB):
http://distro.ibiblio.org/puppylinux/puppy-5.2.8/lupu-528.iso

'devx' SFS file for complete compiling support (135.1MB):
http://distro.ibiblio.org/puppylinux/puppy-5.2.8/lupu_devx_528.sfs

UPDATE NOTICE JAN 8, 2012
Although Lucid 5.2.8 is the last official release, the developers have continued to improve Lucid and have issued 'updates', as PET packages, or you can download an ISO (live-CD) file built with the update. It is recommend to get the latest. Go to the ibiblio.org to find the latest to download:
http://distro.ibiblio.org/puppylinux/puppy-5.2.8/
Or, faster download mirrors can be found here:
http://puppylinux.com/download/
Go here for information about the updates:
http://www.murga-linux.com/puppy/viewtopic.php?t=70855


Lucid Puppy 5.2.5 was the previous release, on April 2, 2011, see announcement:
http://bkhome.org/blog/?viewDetailed=02203

Here is the Forum thread for discussion on development of Lucid 5.2.5:
http://www.murga-linux.com/puppy/viewtopic.php?t=65136
Here is the development discussion prior to release of Lucid 5.2.8:
http://www.murga-linux.com/puppy/viewtopic.php?t=69563
For discussion of the release version 5.2.8, please go here:
http://www.murga-linux.com/puppy/viewtopic.php?t=70855

...note, the above Forum link has more detailed release notes for 5.2.8 in the first post of the thread.

About Puppy "flavours" or editions
For the uninitiated, Puppy Linux releases are built with the Woof build system (http://bkhome.org/woof/), which can build a Puppy from the binary packages of many major distros. The result is binary compatibility with that distro, yet with all the speed and usability of Puppy. We currently have two official "flavours" of Puppy, Lucid (built from Ubuntu binary packages) and Wary (packages originally compiled from source in T2, so not binary-compatible with any particular major-distro). Wary targets older hardware, whereas Lucid has more "bells and whistles" and support for very modern hardware.

If you look on the Puppy Forum, you will find several other flavours of Puppy. For example, there is Fatdog64 for x86-64 CPUs, Slacko Puppy based on Slackware packages -- both of these are at beta status.
Correction: FatDog64 is at Release Candidate stage.


Posted on 8 Jan 2012, 6:51


Comments:

Posted on 19 Aug 2011, 23:54 by Rooey
Is Lucid Upup?
Is Upup a separate distro? or a nickname for Lucid "built from Ubuntu binary packages"?
I download from aarnet because it's unmetered for bigpond


Posted on 20 Aug 2011, 8:28 by disciple
but is it truly any faster?
> Lucid Puppy 5.2.8 is the fastest and friendliest Lucid yet. It is the fastest because it is the first Lucid to use the C and ffmpeg libraries optimized for i686 computers rather than the older i386 computers.

FWIW I think it was established that things haven't truly been compiled for i386 for a long time
http://www.murga-linux.com/puppy/posting.php?mode=quote&p=492620

Also note Amigo's point a bit further down:
> A system compiled for 'pure i686' (march=i686 mcpu=i686) will not run any faster than a system compiled for march=i486 mcpu=i686.


Posted on 21 Aug 2011, 11:28 by playdayz
doesn't seem to hurt anyway
Truly disciple, I don't know. Anecdotally, a few people have said they thought it was quicker, and no one has said they thought it was slower. Ubuntu does go to the trouble of including both the i386 and i686 versions in their iso--so I presume some difference. However, as I have learned from compiling Firefox for my cpu, even when there is a difference it is very subtle--7% or so--I don't think I can notice that in using Firefox.




Posted on 22 Aug 2011, 11:47 by Severian
486
Lucid from Ubuntu is compiled such that it will run on 486 computers. Maverick and up needs a 686 coputer. The main reason for the change was to take advantage of the cmov instruction, Lucid will install and run on processors that do not have the cmov instruction. I use it when repurposing old thin client boxes based on the the VIA c3 or C7 or the geode(all without cmov support).
Debian now compiles their 386 version to need a 486. I don't remember what this buys you, but it does not use the cmov instruction. So, now the question I have is whether Puppy is useful to me any longer on the Via C3, C7, or geode based computers. Is the lupu 528 merely optimized for a 686, or does it require a 686? Will it run on a 486, which is essentially what a C3, C7 or geode is? It would seem like a shame to base it on Lucid, which supports 486 computers and then drop that 486 support.


Posted on 22 Aug 2011, 13:14 by johny why
Good For EEE PC?
hi barry and larry. this page says "UPDATE 2009/03/09:The current version of Puppy Linux 4.1.2 has very good support for the EeePC. The only necessary “hack” was to install the correct wireless driver for 90x and 1000 models."
http://wiki.eeeuser.com/howto:installpuppylinux

is the same true of Lucid 5.2.8?

thanks


Posted on 23 Aug 2011, 14:10 by Severian
march
Howdy,
A correction and a more specific question. The Via C7 does have the cmov instruction. A few C3 CPUs also have it, but not mine.

So, the important question is how were things compiled. If march was set to 686, then the cmov instruction will be used and none of my Via systems can run Puppy 5.28. If it is merely that mcpu(or mtune) are set to 686, and march is still 486, then I will be fine. Can anyone tell me what compiler options were used by whomever put 528 together?
Good day


Posted on 25 Aug 2011, 9:36 by playdayz
more on '686' libc
Concerning Via, I hope someone will test and report. I will check back.

Here's what I know. Ubuntu includes two sets of each of the C and ffmpeg libraries. The one in default position is labeled i386. There is another libc6 "hidden" in /lib/tls/i686/cmov. My guess is that the installer chooses which will be in /lib with the ld-linux.so.2 shortcut. I moved the /lib/tls/i686/cmov library to /lib for 5.2.8. (And then tested tomake sure.)

I have no idea how Ubuntu compiled them.

If there is a problem please let me know--I could make a pet of the i386 libraries.






Posted on 29 Aug 2011, 8:55 by Severian
Puppy, not Ubuntu
Howdy,
I know how Ubuntu compiles libraries for Lucid. They leave march set to 486. The notes for Puppy say "fastest because it is the first Lucid to use the C and ffmpeg libraries optimized for i686 computers". So, the question is how did the compiler of Lucid Puppy compile them.
Good day,
Ralph


Posted on 3 Sep 2011, 2:37 by BobSongs
5.2.8 !! Stellar Puppy Release
Just a brief word to say a big THANKS for Lupu 5.2.8. It fixes so many issues I had with 5.1.0.


Posted on 4 Oct 2011, 4:15 by KapplasCR
Great SO!
This SO is very amazing, since that first look!

Congratulation to Puppy Linux team.

Only a question,

HOW DO FOR DO PUPPY LINUX MORE FAST BECAUSE THE 5.0 VERSION WAS MORE FAST IN MY PC?

BLESS...


Posted on 18 Jan 2012, 5:56 by GCMartin
Additional Puppy Linux Distros
Slacko (32bit CPUs) and (64bit CPUs) are both built with Slackware compatibility.

There is some very common features with these 2 packages. Not only do they present compatible packages via each's PPM, but they start in similar fashions with "single page" localization and both offer SMB2 compatibilty so that they work with all LAN devices manufacuted for compatibility with Apple or Microsoft.

PUPPY 5.28 also has SAMBA 3.61 available, as well, via its PPM, too.

Great compatibilty in the Puppy arena.

All of the Puppy line provides great and stable harmony to this community.
Hope this helps


Posted on 28 Feb 2012, 9:04 by just user
Foreign keyboard(s?)
It was superb idea to create Lucid Puppy, but one obstacle has kept me definitively from adopting Lucid as my (second (:-))) portable system - support of Slovak language. B. Kauler's Wary distro works great from the start, which also means selected qwertz is really it (and does not enforce test window in vain. Lucid Puppy forced me to 5 to 10 tries to select Slovak qwertz support, giving from the start only US or maybe Englsih keyboards effectively when trying different ways to do it, enabling only later by repetition, trial and error intended Slovak, but only Qwerty, despite Qwertz selection. Would't it be better to adopt B. Kauler's approach or at least similar (maybe some other languages could also have similar problem?), given it is so simple and convenient? Generally, also authomatical support (or just hint/howto-link) for switching between U.S. or antoher additional keyboard(s) in the same convenient fashion may would be very helpful.


Posted on 5 Mar 2012, 6:20 by leae89
Debian-based Puppy
Knowing that there are Puppies based on Ubuntu and Slackware, is there gonna be a Debian-based Puppy?