Pnethood, Pprocess, Wallpaper

I have modified these packages to call 'gtkdialog4' instead of 'gtkdialog3':

http://distro.ibiblio.org/quirky/pet_packages-common/pnethood-0.6.8-2.pet
http://distro.ibiblio.org/quirky/pet_packages-common/pprocess-2.2.4-1.pet
http://distro.ibiblio.org/quirky/pet_packages-common/wallpaper-0.6.1-1.pet

Forums threads:
Pnethood: http://murga-linux.com/puppy/viewtopic.php?t=70532
Pprocess: http://murga-linux.com/puppy/viewtopic.php?t=23024
Wallpaper: http://www.murga-linux.com/puppy/viewtopic.php?t=69658

...you will see in those threads that these require the new "development version" of gtkdialog by thunor. These are major applications released by zigbert, clarf and 01micko, that called 'gtkdialog3', and this was one factor that required me to upgrade gtkdialog to the development version, but ended up causing grief with the latest Wary 5.1.4 when we found old scripts were broken.

The clean break now is to name the development version 'gtkdialog4'.

The apps that caused grief in Wary 5.1.4 were zigbert's Pfind, Pburn, Pfilesearch, Pmirror, Pbackup:
http://bkhome.org/blog/?viewDetailed=02452

I have reverted Pmirror to version 0.4:
http://distro.ibiblio.org/quirky/pet_packages-common/pmirror-0.4.pet
http://www.murga-linux.com/puppy/viewtopic.php?t=13606

Pfind is ok, have left it at unmodified version 4.22:
http://distro.ibiblio.org/quirky/pet_packages-common/pfind-4.22.pet
http://www.murga-linux.com/puppy/viewtopic.php?t=15136

Pfilesearch, have left that unmodified at version 1.25, presume it still works with the old gtkdialog3:
http://distro.ibiblio.org/quirky/pet_packages-common/pfilesearch-1.25.pet
http://www.murga-linux.com/puppy/viewtopic.php?t=26764

Pburn, have left that unmodified at version 3.3.5, presume still works with old gtkdialog3:
http://distro.ibiblio.org/quirky/pet_packages-common/pburn-3.3.5.pet
http://www.murga-linux.com/puppy/viewtopic.php?t=23881

Pbackup, have left that unmodified at version 3.1.9, presume works with the old gtkdialog3:
http://distro.ibiblio.org/quirky/pet_packages-common/pbackup-3.1.9.pet
http://www.murga-linux.com/puppy/viewtopic.php?t=10975

In Woof, I have modified all of the package-selection files to build with both the old gtkdialog3 and the new gtkdialog4 PETs. That is, variable PKGS_SPECS_TABLE now has this:

no|gtkdialog2||exe
yes|gtkdialog3||exe|
yes|gtkdialog4|gtkdialog4|exe| #modify all pets that need this to explicitly call 'gtkdialog' or 'gtkdialog4'.


CORRECTION 14 Sept 2011:
It should be:

no|gtkdialog2||exe
yes|gtkdialog3||exe,dev,doc>dev,nls|
yes|gtkdialog4||exe,dev,doc>dev,nls| #modify all pets that need this to explicitly call 'gtkdialog' or 'gtkdialog4'.



Posted on 15 Sep 2011, 19:35


No comments posted yet.