Racy 5.1.99 (5.2alpha)

I stopped uploading earlier, as it got too slow. However, I did manage to upload Racy. Wary is still uploading.

Racy 5.1.99 is "Wary on steroids", the same as Wary except built with Xorg 7.6 (X server 1.11.0) and 2.6.39.4 PAE-enabled i686 kernel.

So, like Wary, but designed for very modern hardware.

Note that for now I have left the "file prefix" as "wary", for example 'warysave.2fs'. A bit later I intend to change that to "racy" so as to differentiate it some more from Wary.

The intention is that the entire collection of apps for Wary will also run in Racy. I have been aiming for very close binary compatibility, despite the bump in the Xorg and Mesa libraries.

The Xorg 7.6 Mega Package can also be installed in Wary, which means that you will get support for later video hardware. But, very important, you will still be using the 2.6.32.x kernel, which might not have drivers for the latest hardware.

For example, my new laptop -- the 2.6.32.x kernel does not have a driver for the ethernet interface, the 2.6.39.x kernel does.

The 2.6.32.x kernel does not have the 'nouveau' nVidia kernel driver, so although the Xorg 7.6 Mega Package has the 'nouveau' Xorg driver, it won't work without the corresponding kernel driver (the post-install script detects the inappropriate kernel and deletes the nouveau Xorg driver so it won't cause any conflict).

Regarding nVidia, with Wary you do have the Xorg 'nv' driver, or you could install the commercial nVidia driver.

With Racy, you will have a choice of all three.

Wary and Racy have my new 'stark' theme. An experiment, I have been looking at it for almost a week now and I am already tired of it. So, it will probably only have this one public appearance.

Anyway, anyone who would like to play with Racy and provide feedback, get it from here:
http://distro.ibiblio.org/quirky/test/racy-5.1.99/


Posted on 17 Sep 2011, 20:28


Comments:

Posted on 17 Sep 2011, 20:40 by Terryphi
Racy Test
Racy works fine for me as new frugal install. Sound worked and wired connection detected without problem. Booted up at default resolution which does not suit me but I was able to reset resolution to 1024x768 and this was saved on reboot.

However, trying to use a warysave.2fs from Wary did not work. Is it supposed to? It booted up to a black screen with bar at bottom. Running xwin from command line produced fatal error. Message flashes too quickly to read fully but I think it was complaining about a missing usb... module.



Posted on 17 Sep 2011, 21:29 by BarryK
Racy feedback on forum
I have started a forum thread for Racy feedback:

http://murga-linux.com/puppy/viewtopic.php?t=71767

Terryphi,
Yeah, there might be trouble with an existing warysave.2fs file. That's why I should change to 'racy' prefix in the future.

It should be ok to use an existing warysave if you upgrade to latest Wary then install the Xorg 7.6 Mega Package.

Your warysave.2fs probably has some Xorg 7.3 files in it, which will on top of the Racy SFS in the layered filesystem. It might be possible to put some code into /etc/rc.d/rc.update that can fix that problem.

But for now, I will have to say, do not upgrade a pre-existing warysave file.

Yes, I am very interested to know about the success or otherwise of the automatic Xorg setup. Like, has it chosen the right driver, right resolution?



Posted on 17 Sep 2011, 21:33 by BarryK
Forum link
That is:

http://murga-linux.com/puppy/viewtopic.php?t=71767



Posted on 17 Sep 2011, 21:44 by Terryphi
Automatic Xorg setup
It chose the right driver for my Intel hardware. As for resolution, I think 1024x768 is the right resolution (for my eyes) - but Xorg has always forced a higher resolution. Resetting to 1024x768 has always required a few tweaks to the parameters. The parameters it uses just don't seem right for some hardware at 1024x768.


Posted on 18 Sep 2011, 2:17 by broomdodger
shasum
wary5141
racy519
wary519

md5sum and sha256sum are available without dev
shasum is only available with dev

Is this by design?


Posted on 18 Sep 2011, 7:55 by BarryK
re shasum
sha256sum and sha512sum are Busybox applets, shasum is a Perl script, part of the Perl package.

It seems that shasum needs Perl modules that are in perl_DEV PET, not available in the cut-down Perl in the main SFS.

However, something that needs to be checked out, whether Busybox can be configured to create 'sha1sum', which is the equivalent of shasum.



Posted on 18 Sep 2011, 10:21 by broomdodger
FlSynclient and...
Dell Latitude CPx J650GT 256MB RAM
(recently given to me)

FlSynclient
wary5141 works
wary519 works

racy519 "No synaptics driver loaded?"
otherwise racy seems to work

Something strange about all three:
after the screen with
<administrator> < fido >
it takes about 2 minutes for the next screen to show, at first I thought it had frozen. On the next boot attempt I was interrupted and when I came back, to my surprise, it went on normally.

Then I forced another boot from RAM and got the same hang, but timed it... about 2 minutes!

I have not seen this on any other machine.

Later I will try an puppy 431



Posted on 18 Sep 2011, 12:56 by broomdodger
FlSynclient and slow pupsave dialog
ok some more tests all frugal

431 all pupsave dialogs fast

512 all pupsave dialogs fast -- FlSynclient works

513 pupsave dialog "fido" 2 minute delay -- FlSynclient works

What changed between 512 and 513?



Posted on 18 Sep 2011, 15:33 by BarryK
Flsynclient
Flsynclient works in Racy for me. Your error message means that the Xorg synaptics driver did not load.

Open /var/log/Xorg.0.log, search for "synaptics" -- it should tell you why it failed.

I wonder... I am using the automatic startup of X. Did you use the Xorg Wizard?



Posted on 19 Sep 2011, 4:48 by broomdodger
Flsynclient
Barry Master Puppy Trainer

Yes, I did use Xorg Wizard after I thought racy had hung at the 'fido' dialog.

Restart, new pupsave and Flsynclient works on that Dell Latitude. Everything seems to work great. But still the delay after the 'fido' dialog.

Then tried racy on the Panasonic ToughBook 366MHz, 192MB ram, 512MB Linux-swap. Runs great.

No Flsynclient but I do not think the hardware supports it. Nothing in the Xorg.0.log about synaptics at all.

Now the strange thing again, the ToughBook has NO delay after the 'fido' dialog! So what is up with the Dell?


Posted on 19 Sep 2011, 12:16 by broomdodger
sha1sum
I filed a bug report about sha1sum missing in BusyBox v1.17.2 (not shown when typing "busybox" at cli)

I tried:
busybox sha1sum file.txt
sha1sum: applet not found
but
busybox sha256sum file.txt
works.

It is now listed in the current BusyBox 1.19.2



Posted on 20 Sep 2011, 9:06 by broomdodger
sha1sum bugzilla reply
Hi Barry

I got this reply from bugzilla:

https://bugs.busybox.net/show_bug.cgi?id=4213

Denys Vlasenko <vda.linux@googlemail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |RESOLVED
Resolution| |WORKSFORME

--- Comment #1 from Denys Vlasenko <vda.linux@googlemail.com> ---
Works for me:

$ tar xf busybox-1.17.4.tar.bz2
$ cd busybox-1.17.4
$ make defconfig
...
$ make
...
$ ./busybox sha1sum <LICENSE
c47a888f2be626e1197b6f651dee966ef882077d -



Posted on 20 Sep 2011, 9:57 by broomdodger
sha1sum bugzilla reply
and... yes, I just compiled busybox-1.17.4
it now does have sha1sum.

I guess the only question is whether something else got broken.

I also compiled busybox-1.19.2 just to see if I could. sha1sum, sha256usm, sha512sum all work.


Posted on 20 Sep 2011, 21:04 by BarryK
missing sha1sum
Yes, 1.17.2 likely does have sha1sum. When I run the configure, I don't turn on everything.

You can see example .config files for Busybox in my sources repo:

http://bkhome.org/sources/alphabetical/b/



Posted on 21 Sep 2011, 2:33 by broomdodger
missing sha1sum
tried to see the config file but requires user and password



Posted on 21 Sep 2011, 7:25 by broomdodger
missing sha1sum ok
ok I remembered and can see the .config