Wary Puppy 5.2 released

The last official release of Wary Puppy, our build or "edition" of Puppy Linux that targets older hardware, was on September 1, 2011, see announcement:
http://bkhome.org/blog/?viewDetailed=02454

Since then, development has continued at an intense pace. As this extraction from the Wary 5.2 Announcement page states:

This is a massive upgrade relative to the 5.1.x series. All of the base packages were recompiled in T2. Certain choices were made in T2 with the plan of seamless upgrading from Xorg 7.3 to 7.6 -- that is, the default Wary system has Xorg 7.3, but it is planned that Wary can be upgraded to Xorg 7.6 by installation of a single PET package, and all applications will work before and after. This required some very careful configuration. The idea is to "have our cake and eat it too" -- Xorg 7.3 for old hardware, easy upgrade to 7.6 for newer video hardware. The plan actually seems to be working.
As usual, huge changes yet only a small version-number change. Many bug fixes, upgrades, new packages.


There are fascinating new features in this Puppy. Take the time to peruse the Announcement and Release Notes page:
http://distro.ibiblio.org/quirky/wary-5.2/release-Wary-5.2.htm

Also, for an introduction to what Wary is all about, read this page:
http://bkhome.org/wary/

The live-CD ISO file is 123.6MB, which might seen pretty small, yet it could have been much smaller -- the build has the "kitchen sink" in terms of kernel drivers, for example very large 3rd-party analog modem drivers. Download:
http://distro.ibiblio.org/quirky/wary-5.2/wary-5.2.iso

All the tools needed for C/C++/Vala/BaCon coding and compiling are in this SFS file (109.7MB):
http://distro.ibiblio.org/quirky/wary-5.2/devx_wary_5.2.sfs
(SFS files are introduced here:
http://puppylinux.com/development/package-management.htm)

Extra release notes

1. The Puppy Package Manager can install PET packages from the 'wary5' repository. However, we need to test all of the packages in that repo, that they still work. One issue is that 'ffmpeg' got updated in latest Wary, which might have broken a couple of the media player PETs (Gnome-mplayer, Smplayer). This testing will be done ASAP.

2. The pup has the 2.6.32.45 kernel, configured with SMP (multiple CPU cores) support enabled. I did also compile a uniprocessor kernel, however in alpha/beta testing no-one reported a failure with the SMP-enabled kernel on a uniprocessor system that was fixed by using the uniprocessor-enabled kernel. Hence, I have not built a uniprocessor version of Wary 5.2.

3. I am still not 100% certain that an old save-file will upgrade correctly. If you have a save-file from an earlier version of Wary, booting up with 5.2 should upgrade it ok -- if X fails, try rebooting -- if X still fails, try with boot parameter "puppy pfix=purge".

4. Wary 5.2 has a new theme. I would especially like to thank forum member 'dejan555' for the lovely wallpaper. I posted about the theme here:
http://bkhome.org/blog/?viewDetailed=02538


Posted on 14 Oct 2011, 7:07


Comments:

Posted on 14 Oct 2011, 7:41 by BarryK
Wary 5.2 Forum feedback
Any feedback on Wary 5.2 can be posted to this thread in the Puppy Linux Forum:

http://murga-linux.com/puppy/viewtopic.php?p=572975#572975



Posted on 14 Oct 2011, 8:51 by GCMartin
Uniprocessor
This boots fine and operates superbly on P3 and a non-hyperthreading P4. Simply, Great!


Posted on 14 Oct 2011, 8:54 by broomdodger
Glade Interface Designer icon missing
wary 5.2.0
frugal
devx_wary_5.2.sfs loaded

Glade Interface Designer icon missing



Posted on 14 Oct 2011, 14:21 by Terryphi
Old savefile breaks Wary
As previously reported using savefile from Wary 5.1.4.1 breaks Wary 5.2 even when using pfix=purge.
Black screen but with bar at bottom from which I can run some added programs but not rox or Puppy programs.

Is this anything to do with new gtkdialog ?


Posted on 14 Oct 2011, 14:24 by Sage
5.2
Downloading, will test later. 106 was excellent.

- which version of EudoraOSE.pet is most likely to work? I have two at present.


Posted on 14 Oct 2011, 17:06 by Sage
5.2
Woofwoof missing!


Posted on 14 Oct 2011, 17:17 by tronkel
What does future hold now
Looks as though this latest version of Wary has just obsoleted every previous version - because of the the quantum-leap improvements under the hood.

Should this Wary 5.2 version not now be considered to be the official Puppy for the end users as well as a working base for the Puppy derivative developers? Does the Woof tree allow say a Slackware or Ubuntu variant to be built using this Wary 5.2 as its base?

Congratulations on this milestone version Barry - what an humongous achievement! I wonder what will happen to the Distrowatch rating now.


Posted on 14 Oct 2011, 18:16 by Sage
Woofwoof
...as you were. The old problem with old kit - sound not working by default. Anything older than about 3-4yrs may need ALSA to be run. Chicken and egg for testing, though. Need a default Woofwoof before fiddling with settings!


Posted on 15 Oct 2011, 3:01 by Iguleder1
Wildcards in Woof
Barry - I just found some bug in Woof. When you use a wildcard in the second field (e.g the package names), Woof only applies this selection to one package list.

I'm trying to build a dpup with the Debian Backports mirror and I got a broken X because of this - Woof only picked the packages from the backports repository but kept the ones from the Squeeze repository out.


Posted on 15 Oct 2011, 6:05 by broomdodger
pupX set properties of X
Wary 5.2 frugal

pupX set properties of X > Screensaver

Usually I disable the screen saver,
but just now enabled it for a short delay,
and 'blank the screen'.

It did not happen !
I tried it with no apps running.

Is it broken?




Posted on 15 Oct 2011, 8:50 by GCMartin
PPM Package can't find libs
Found PPM pacakges that does NOT install and run adequately.

I will PM you with those details.

it seems WARY libraries may be problem.


Posted on 15 Oct 2011, 9:50 by scsijon
eudora and xorg 7.6
@sage and interested others.

I shall create a wary52 packaged eudora in a couple of days (mon-tue), check www.lamiaworks.com.au/puppy.html although I suspect the w5 pet should work out of the hat.

@barry and interested others.

I built a (rough) 106 with xorg 7.6 as well as the same with xorg 7.4 using woof, just to do a comparison. I found that the 7.6 clearly seems to run faster, it also runs on my old hardware, even those that I had problems with with 7.4 earlier! I wonder why?

regards
scsijon


Posted on 15 Oct 2011, 12:57 by scsijon
xorg7.6
sorry, I mean using xorg 7.6 works, but using xorg 7.4 fails.


Posted on 15 Oct 2011, 13:45 by broomdodger
xorg 7.6 + pupX set properties of X
wary 5.2 frugal xorg 7.6
Screen saver blanking works!
--AND--
glxgears is 2x faster than xorg 7.2
xorg 7.2 1120 frames in 5.2 seconds = 216.024 FPS
xorg 7.6 2363 frames in 5.0 seconds = 472.455 FPS

Both using the vesa driver by choosing i810



Posted on 15 Oct 2011, 14:23 by broomdodger
xorg 7.6 + flsynclient = crash
acer Aspire ONE
wary 5.2 frugal xorg 7.6

flsynclient > click calibrate touchpad and crash

xorg 7.2 no problem



Posted on 15 Oct 2011, 14:57 by Sage
Link problem
scsijon's link to his website points straight back to your blog, Barry!


Posted on 15 Oct 2011, 16:49 by BarryK
Re: Wildcards in Woof
Iguleder,
Did you try to force which repo to use? Ex:

# yes|abiword|iceword,iceword-plugins|exe,dev,doc,nls|compat:salix

...'salix' is one of the Slackware repos, the database file Packages-slackware-13.37-salix.

The override, in above example "salix", can be any one of the fields in the filename "Packages-slackware-13.37-salix".

That override should also work if you have wildcards in 3rd field.



Posted on 15 Oct 2011, 16:58 by BarryK
Re2: Wildcards in Woof
This override mechanism was introduced here:
http://bkhome.org/blog/?viewDetailed=02414

Of course with Debian, the database files have different names. I don't know anything about the backports. The standard Debian db files will be:

Packages-debian-squeeze-main
Packages-debian-squeeze-non-free
Packages-debian-squeeze-contrib

So you could for example have:

yes|abiword|iceword,iceword-plugins|exe,dev,doc,nls|compat:contrib

...in which case, it is unlikely that you would need the wildcards.



Posted on 15 Oct 2011, 17:46 by BarryK
Slow Xorg 7.3
Some Wary testers have reported sluggish Xorg 7.3 (before they tried the Xorg 7.6 upgrade).

Try this, see if it improves speed:

http://www.murga-linux.com/puppy/viewtopic.php?p=573344#573344



Posted on 15 Oct 2011, 18:00 by Iguleder1
Re: wildcards
Barry - no, this isn't the problem. These are "compatible distro" packages anyway. The problem is that some of them originate in one repo and the others in another. When I use a wildcard, Woof picks only the packages from the first repo.

I can't put that field, since it will force one repository and the other packages will be missing.


Posted on 15 Oct 2011, 19:28 by Sage
Link problem
...still misdirecting!


Posted on 16 Oct 2011, 7:18 by scsijon
link problem
try typing it in as shown sage, I have no idea why the blog is putting it's name in front


Posted on 16 Oct 2011, 7:36 by BarryK
Link problem
Probably it needs the http:// in front, otherwise treats it as a local link:

http://www.lamiaworks.com.au/puppy.html



Posted on 16 Oct 2011, 7:56 by BarryK
Re3: Wildcards in Woof
Iguleder,
Could you get by with splitting it up, for example:

yes|iceword|iceword-2*|exe,dev,doc,nls|compat:main
yes|iceword-plugins|iceword-plugins*|exe,dev,doc,nls|compat:contrib




Posted on 16 Oct 2011, 13:11 by scsijon
eudora link plus use
sorry barry, will remember for next time.

on the other hand I thought i'd try the existing wary5 version before repackaging and it works properly providing you install it's two (dbus, dbus-glib) dependancies before installing it.

please remember you need to reboot after installing dbus and give Eudora a little time to set itself up when started the first time, it has to setup a few files, links and the like for the user.


Posted on 16 Oct 2011, 14:48 by Sage
link & Eudora
Thanks for those clarifications, guys.
Of course, I did type in the link! Can I ask a supplementary, please? Do we need those two dbus files if we d/l the Eudora file on scsijon's link? Or are those just for folks using the Wary5 version (presumably still in the repo?)?
http://www.lamiaworks.com.au/puppy.html


Posted on 16 Oct 2011, 23:20 by Terryphi
Fix for old warysave file
Forum member upnorth has posted a fix for the problem where a savefile from an earlier version of Wary breaks Wary 5.2.

http://www.murga-linux.com/puppy/viewtopic.php?t=72258&start=94


Posted on 17 Oct 2011, 5:15 by witek_w11
I found a bug.
Geeqie starts ok, but when we klik on folder with images then application collaps. In console types: segmentation fault.


Posted on 17 Oct 2011, 10:28 by scsijon
@sage + eudora
you need to check if your version has these two packages in by default or add them from their own, wary doesn't which is why I put them there, hidden directory file /root/.packages/woof-installed-packages is your friend here.

pm me (same name) on murga-linux.com if further help required, were getting off-topic here

sorry barry


Posted on 17 Oct 2011, 14:41 by Sage
"we're getting off-topic here"
... not necessarily? Your valuable insight may assist with other Wary-related issues.

Either way, many thanks sj and BK - much appreciated.

PS Folks who haven't tried Eudora yet might be missing a trick.


Posted on 18 Oct 2011, 13:07 by cbs
Request
Installed frugal on my old Sony laptop.
Works wonderfully well.
However, i would like to request if it is possible to update Viewnior to v.1.0 or 1.1
I would like to use the crop function found only in later versions.
Thank you for your hard work.


Posted on 22 Oct 2011, 2:49 by broomdodger
tray cpu graph - how to add click
wary 5.2

How / where to edit to add clicking the cpu graph in the tray so it will open a file such as top or hardinfo?




Posted on 27 Oct 2011, 7:02 by BarryK
Wary 5.2 printing fix
Notice to Wary 5.2 users
Fix for printing

Printing from some applications is broken. Explanation and fix here:
http://bkhome.org/blog/?viewDetailed=02567

This will be in the next Wary, but you can grab the fix now.



Posted on 28 Oct 2011, 22:34 by BarryK
Wary Service Pack 5.2 - 5.2.1
Wary 5.2.1 is a bug-fix release. Currently only available as a PET package for Wary 5.2:

http://bkhome.org/blog/?viewDetailed=02573



Posted on 12 Nov 2011, 15:49 by pupok
cpu
p 3 800mhz 128 ram and p 4 1400mhz 512 ram do not work well with the latest kernel, very heavy CPU


Posted on 12 Nov 2011, 16:19 by BarryK
Re heavy CPU
pupok,
You might have better luck with the upcoming Wary 5.2.2, which has a uniprocessor kernel. A couple of testers have reported that this has less CPU usage.