WebKit compile fail

So far, anyway. I did compile WebKit successfully once before. This time, I compiled all the dependencies, no problem there. Then started WebKit compiling, and it went on for ages.

Finally, stopped with:
make[1]: Entering directory `/mnt/sda10/downloads/input216/0-midori/webkit-1.7.1'

CXXLD Programs/DumpRenderTree
./.libs/libWebCoreInternals.a(libWebCoreInternals_la-Internals.o): In function `WebCore::Internals::createShadowContentElement(WebCore::Document*, int&)':
Internals.cpp:(.text+0xcba): undefined reference to `WebCore::ShadowContentElement::create(WebCore::Document*)'
collect2: ld returned 1 exit status
make[1]: *** [Programs/DumpRenderTree] Error 1
make[1]: Leaving directory `/mnt/sda10/downloads/input216/0-midori/webkit-1.7.1'
make: *** [all] Error 2


This is WebKit version 1.7.1. That error message is double-Dutch to me. I will try a different version of WebKit.


Posted on 31 Oct 2011, 8:01


Comments:

Posted on 31 Oct 2011, 17:48 by scsijon
Midori Webkit error?
Source from Twotoasts.de I take it?


Posted on 31 Oct 2011, 17:52 by Sage
Perth
This morning, we learn that Perth is the most remote community on the planet. Such are the misapprehensions that Mercator visits upon us.


Posted on 32 Oct 2011, 6:33 by BarryK
WebKit 1.6.1 failure
I tried WebKit 1.6.1, the latest stable release, same compile error.



Posted on 32 Oct 2011, 6:42 by BarryK
WebKit: I give up
I also tried with less/more/different 'configure' options.

A problem with C++ is is that often the error messages can be obscure, as in this case. I lack the expertise to analyse the code and track this error.



Posted on 32 Oct 2011, 6:44 by BarryK
twotoasts.de
Yeah, twotoasts.de.

Anyway, I am moving on.



Posted on 7 Nov 2011, 6:26 by scsijon
buildline
can I have your buildline please,

as I had no problems using the defaults with the latest nightly download r98912 of 1.7.1. for a GNU build.


Posted on 7 Nov 2011, 10:54 by BarryK
Re Webkit build
Here ya go:

libgpg-error 1.9

# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --disable-shared --disable-nls --disable-languages

libgcrypt 1.5.0
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --disable-shared --disable-padlock-support

gnutls 2.12.1
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --disable-gtk-doc-html --disable-shared --with-included-libtasn1 --without-p11-kit --with-lzo --with-libgcrypt

glib-networking 2.28.7
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --without-ca-certificates

libsoup 2.35.5
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --enable-debug=no --without-gnome

gperf 3.0.4
needed by webkit
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var

icu4c 4.8.1
hmmm, even though specified '--with-unicode-backend=glib' for webkit, it still want icu lib installed...
# mv icu icu-4.8.1
# cd icu-4.8.1
# cd source
# ./runConfigureICU Linux --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --disable-shared --enable-static --disable-tests --disable-samples
# make
# new2dir make install

gstreamer 0.10.35
hmmm, i think might be good to have as shared lib, other apps can use it...
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --enable-shared --disable-examples --disable-tests --disable-valgrind --disable-check

gst-plugins-base 0.10.35
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --disable-examples --disable-valgrind --disable-gnome_vfs --disable-debug


...comment too long


Posted on 7 Nov 2011, 10:56 by BarryK
Re Webkit build part 2


webkit 1.7.1
from forum (topic 65703, build a 3M Midori):
# patch -p1 < ../webkit-jemimah.patch
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-t2-linux-gnu --enable-static --disable-shared --with-unicode-backend=glib --with-gtk=2.0 --enable-spellcheck --disable-schemas-compile



Posted on 29 Nov 2011, 24:05 by jemimah
dumpRenderTree not needed
DumpRenderTree and some of the other test programs don't always like to build - especially with a static webkit. However, you can just comment them out of the GNUMakefile and continue the build and things end up fine.

Midori is now available here:
http://murga-linux.com/puppy/viewtopic.php?t=73799


Posted on 1 Dec 2011, 10:27 by BarryK
Re Midori crash
See my later post:

http://bkhome.org/blog/?viewDetailed=02613



Posted on 11 Dec 2011, 3:14 by webkit
webkit
I suspect that with webkit the latest is not the best. In Slackware 1337 I got using Slack packages http://webkitgtk.org/webkit-1.3.4.tar.gz. It seems fairly stable indeed my main browser is a simple pygt webkit app. Now this is 64 bit and not same as puppy but in general both Arch and Slack seem to have better version of webkit gtk than Ubuntu.


Posted on 20 Jan 2012, 24:19 by pipo
Detailed instructions HOWTO build
Could you please
give detailed instructions how to build it?
What needs to be modified in the GNUmakefile.am?