Wary and Racy 5.2.2 "TESTING"

If anyone is interested in conducting a "sanity check", here they are:

http://distro.ibiblio.org/quirky/racy-5.2.2TESTING/

http://distro.ibiblio.org/quirky/wary-5.2.2TESTING/

About several hours from now I intend to remove the "TESTING" from the directory names and formally announce the releases.


Posted on 18 Nov 2011, 4:23


Comments:

Posted on 18 Nov 2011, 8:13 by pemasu
very quick sanity test
Acer 5820TG laptop. Boots fine. Quickset works ok. Intel driver needed to be changed by xorgwizard, works with intel ok. Welcome1stboot appears. 2 barks ok. wireless ath9k connection without problem.
Same with previous versions, touchpad lacks the exact precision. But it is about usable. Planner starts. Retrovol shows settings ok.
/tmp/xerrs.log shows this: (retrovol:26498): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated


Posted on 18 Nov 2011, 8:54 by james c
wary 5.22 sanity check
Quick manual frugal install on Athlon XP box.Sound ,internet and display (old Nvidia card) all good on initial boot.Manually installed latest Flash... no SeaMonkey problems.Looks good from this quick glance.


Posted on 18 Nov 2011, 12:44 by MagicZaurus
Quick Test Racy
Tested for a few minutes and no major problem seen. Having a SD card inserted the label for the drive icon (mmcblk0p1) overlaps with sda1. That's just a small cosmetic nag. SeaMonkey working nicely with Flash plugin.


Posted on 18 Nov 2011, 13:58 by broomdodger
racy 5.2.2 sanity check
IBM ThinkPad x30, 1.2GHz single core, 512MB ram
Note: racy 52190 all worked well except flash and auto wifi

racy 5.2.2
frugal manual install

1. start to black screen
nothing works
force shutdown

2. restart no desktop
use 'Menu' to reboot

3. restart no desktop
Lighthouse report = vesa
use 'Menu' exit to prompt
xorgwizard - probe
xwin
Lighthouse report = intel
usually vesa has been faster than intel
but this time intel is fast

4. wifi not automatically detected
connect to wifi manually ok
flash installed
test some pages with flash, ok! no delays, very smooth
no insert key problem

5. install devx_racy_5.2.2.sfs
Utility > Glade Interface Designer - 'icon' STILL missing

6. Note: Pmusic has been updated to 2.2.2 with many fixes

7. compile Vim 7.3.353
gtk2 not found, X11-Athena GUI compiled
worked in racy 52190 and 52191
tried:
--enable-gui=gtk2
--enable-gui=gtk2 --disable-gtktest
--enable-gui=gtk
all fail and compile a non-GUI version

-Bill





Posted on 18 Nov 2011, 15:07 by Terryphi
Racy & Wary OK
Both running OK on initial tests.


Posted on 18 Nov 2011, 15:45 by Sage
TESTING
Sorry couldn't make that schedule due to the mismatch between timezones and my commitments.
Won't know now until Sunday, GMT.


Posted on 25 Nov 2011, 17:52 by dpup5520
ntfs issues
Been having a go with Racy for the most part of a day now, only real issue i've seen is with ntfs-progs/3g , Racy is throwing errors whenever I try to copy or move files in a ntfs partition


Posted on 25 Nov 2011, 22:12 by ttuuxxx
Racy fails to compile libcanberra
Hi Barry, I've tried to compile 6 different releases of libcanberra and each get hundreds of Gseal errors that stops the build, Here's the sources http://0pointer.de/lennart/projects/libcanberra/libcanberra-0.28.tar.gz
I usually compile it statically and --disable-oss --disable-schemas-install extras add
ttuuxxx




Posted on 25 Nov 2011, 22:18 by ttuuxxx
Racy fails to compile Metacity
Hi Barry I just tried to compile metacity and it also had the Gseal issue with hundreds of errors, I think I recall a patch for gtk2 which dealt with this.
ttuuxxx


Posted on 28 Nov 2011, 3:23 by ttuuxxx
ignored
Hi Barry I was lending a hand to build the next community edition and I couldn't compile libcanberra, metacity, or even lxtask, they all had hundreds of Gseal errors. Really everything is on hold until you work it out.
ttuuxxx


Posted on 28 Nov 2011, 7:42 by BarryK
re gseal
ttuuxxx,
I have never encountered the "gseal" error myself, so know nothing about it. I am in the same situation as you. If you could find that gtk2 patch, that would be good.



Posted on 28 Nov 2011, 21:26 by ttuuxxx
re:re:Gseal
Hi Barry I downloaded the gtk2.24.8 sources and looked at the configure script located in /root/Downloads/gtk+-2.24.8/configure and searched for Gseal
this is what what the configure script says

#ifndef GSEAL

/* introduce GSEAL() here for all of Gdk and Gtk+ without the need to modify GLib */
# ifdef GSEAL_ENABLE
# define GSEAL(ident) _g_sealed__ ## ident
# else
# define GSEAL(ident) ident
# endif
#endif /* !GSEAL */


It has to be enabled I think,

I found a patch located at
https://bugzilla.xfce.org/attachment.cgi?id=3554&action=edit


Posted on 29 Nov 2011, 5:30 by BarryK
Re gseal patch
ttuuxxx,
That patch looks like a fix for Xfce to compile with gtk 2.24. It is not a patch for gtk.



Posted on 31 Nov 2011, 3:53 by ttuuxxx
Bluemoon
Hi Barry I updated my blue moon icon theme for Racy, since your using a newer icon format its even smaller now. http://www.smokey01.com/ttuuxxx/Racy/Blue-Moon-Icon-Theme-Racy.pet
ttuuxxx


Posted on 31 Nov 2011, 4:16 by FeodorF
Gray's Racy-NOP
Gray has put together a wonderful piece of software based on Racy-5.2.2

http://www.murga-linux.com/puppy/viewtopic.php?t=73728


Posted on 31 Nov 2011, 4:27 by ttuuxxx
Gseal
Hi Barry I re-downloaded racy and the devx, used a new cd, and still getting Gseal errors with just about everything I try to compile live.
This is how I've always compiled live.
First I unsquashfs the devx like
unsquashfs4 /root/my-documents/devx_racy_5.2.2.sfs
then I rename the folder /root/squashfs-root to devx_racy_5.2.2
then I dir2pet devx_racy_5.2.2
and install the pet.

That's what I've done since the early 2 series.

I tried to compile a small "C" titris game http://sourceforge.net/projects/gtktetris/files/gtktetris/gtktetris-0.6.2/gtktetris-0.6.2.tar.gz/download
and this was most of the Gseal errors I got, http://pastebin.com/34E9kciJ
There was way too many to post here, so i used pastebin,
thanks for your help
ttuuxxx


Posted on 31 Nov 2011, 4:41 by ttuuxxx
Gseal fixed kind of
Hi Barry I installed
ftp://ftp.nluug.nl/pub/metalab/distributions/quirky/pet_packages-wary5/gtk+-2.24.5-w5c.pet
ftp://ftp.nluug.nl/pub/metalab/distributions/quirky/pet_packages-wary5/gtk+_DEV-2.24.5-w5c.pet
and just about everything compiled, there was only one error after that
/usr/lib/gcc/i486-t2-linux-gnu/4.3.4/../../../libgtk-x11-2.0.so: undefined reference to `gdk_pixbuf_format_get_type'
collect2: ld returned 1 exit status
make: *** [all] Error 1
so I installed
ftp://ftp.nluug.nl/pub/metalab/distributions/quirky/pet_packages-wary5/gdk-pixbuf_DEV-2.22.1-w5c.pet
ftp://ftp.nluug.nl/pub/metalab/distributions/quirky/pet_packages-wary5/gdk-pixbuf-2.22.1-w5c.pet
and the tetris game compiled perfectly :)

ttuuxxx


Posted on 31 Nov 2011, 6:48 by BarryK
Re Gseal "fix"
Ha ha, the gymnastics we sometimes have to perform!

I had such a painful time getting that gtk library to work properly for 5.2.2, I don't want to touch it anymore.



Posted on 5 Dec 2011, 12:14 by WN2A
RACY 5.2.2 --SUPER!
After testing nearly every recent Puppy Release (except dpup) , I will say this is the only one since 4.3.1 that worked flawlessly upon frugal install to HD on my Acer Aspire 5733Z. Added GUVCView, LibreOffice,Inkscape, Wine, and Qucs/Asco.
Very impressed with the stability. Racy Puppy is so well behaved and feature rich, Barry!