NTFS, Pmount, Partview, rc.shutdown, 10alsa fixes

In the Racy 5.2.2 Forum feedback thread, member otropogo reported error messages when copying files to/from an NTFS partition. Member shinobar replied that this is due to file permissions being lost in the transfer and the file is still copied ok. Shinobar showed a fix for /bin/mount to remove the error messages:
http://www.murga-linux.com/puppy/viewtopic.php?t=71767&start=375

...I have implemented shinobar's fix in Woof. Note that older versions of ntfs-3g do not have this problem, which is why it has occurred in recent puppies.

Forum member otropogo reported that the 'preferences' in Pmount is broken:
http://www.murga-linux.com/puppy/viewtopic.php?t=71767&start=375

I have fixed /usr/sbin/pmount. In the case of 'mut2', this is an alternative to 'probepart' and 'probedisk' that was developed by Jesse Liley. If missing, the preferences window now puts up text that the 'mut2' package is required.

mut2 has not been developed for a long time, and I don't know how well it works. It is not included in Puppy anymore.

otropogo also wrote this, after failing to get F-Prot working:

So then I tried to install clamav, which I've read Barry prefers to the "broken" f-prot. There's only one package in the repos clamav-0.91.2.pet, in the Puppy 3 repository. I installed it "successfully", but no tab or icon for it appears anywhere, and I have no idea how to access it to run it or update its sigs file.

Incorrect, I recommended Avast, for which there is a PET package for Wary/Racy:
http://bkhome.org/blog/?viewDetailed=02494

Karl Godt reported a problem with the 'sort' utility in Partview:
http://www.murga-linux.com/puppy/viewtopic.php?t=71767&start=390

...I have modified the Partview package, it is now 'partview-2.2-1.pet', in the 'noarch' repo.

...I should have read further down the thread, Karl determined the problem to be something else and posted a patch. I don't really know what problem is being fixed, anyway I have applied the patch. Rather, patch failed, did it manually.

In same thread link above, Karl Godt reported a bug in /etc/rc.d/rc.shutdown, unmounting stray partitions. Fixed.

In same link, Karl Godt posted a fix for unloading sound modules, in /etc/init.d/10alsa. Applied. Actually, patch failed, did it manually.

Woof commit:
http://bkhome.org/fossil/woof2.cgi/info/80b4545f72


Posted on 3 Jan 2012, 16:45


Comments:

Posted on 16 Jan 2012, 16:21 by ecube
Partview FULL-install correction
Hi Barry,

You state

Quote:
...I have modified the Partview package, it is now 'partview-2.2-1.pet', in the 'noarch' repo.


I have contacted Karl Godt but couldn't clearify the content of his modification. However, when testing Partview for FULL-install I found a bug caused by the notation /dev/root for the partition mounted on /.

I have unsuccesfully tried to send you a PM with a corrected version of pdff.pl. The error message was "Couldn't get mail server response codes".

Regards,

Olov


Posted on 16 Jan 2012, 20:36 by BarryK
re contact me
ecube,
Send it by email STARTbkaulerATgmailDOTcomEND