Mini-translation for QuickSetup

When someone chooses a non-English locale in QuickSetup, a window comes up advising about availability or otherwise of a langpack in the chosen language.

To improve the user experience, I would like that window to display in the user's language. So, I would like to obtain translations for as many languages as possible, for these:

AVAILMSG="There is a suitable \Zb${AVAILPACK}\ZB package in the \Zbnoarch\ZB PET repository, in the \ZbSetup\ZB category. After you have an Internet connection, click the \Zbinstall\ZB icon on the desktop to run the Puppy Package Manager, then choose the repository and category.

Note: Before downloading the langpack, you will have to make an Internet connection and use the Puppy Package Manager in English. If you think that you cannot read English sufficiently, an alternative is to run another operating system, go to http://distro.ibiblio.org/quirky/pet_packages-noarch and download the langpack. Then, boot Puppy, click the partition icon on the desktop to mount the partition (where you downloaded the langpack to), then click on the langpack PET to install it."

AVAILMSG="Official langpacks are available in the \Zbnoarch\ZB repository, however there is not one for your language. Perhaps there is one under development in the Puppy Forum (be careful, some older versions of Puppy have incompatible langpacks). Or, perhaps you might volunteer to help out and create a langpack -- click the Menu -> Help -> HOWTO Internationalization (you will of course need a good knowledge of English)."

pupdialog --background '#8080FF' --colors --backtitle "Language pack needed" --msgbox "The locale will be changed to ${LANGCHOICE}, but you need to install a language pack to translate Puppy to your language. You need a PET package named \Zblangpack_${LANG12}\ZB or \Zblangpack_${LANG1}\ZB. We have not yet automated this, so you will have to download and install the package. You may do this any time in the future. Officially supported langpacks are available by running the Puppy Package Manager (click the \Zbinstall\ZB icon on the desktop), in the \Zbnoarch\ZB repository.
${AVAILMSG}" 0 0


What I was thinking of doing is put a case statement in the script, to display the correct translation. Note, as the translations are being placed directly into the script, gettext is not needed.

So, for anyone reading this, if are fluent in another language, you are invited to respond!

Note, when you post a comment, click the 'code' button to get the code tags, then paste your translation in between the tags.


Posted on 13 Mar 2012, 9:43


Comments:

Posted on 13 Mar 2012, 18:04 by esmourguit
French translation
Hello Barry
I tried to send the french translation but :
The content is too long! Max characters is 2000 you typed 2364
I will try to reduce the french translation under 2000 characters, if possible.


Posted on 13 Mar 2012, 18:17 by esmourguit
French translation
AVAILMSG="Il y a un paquet \Zb${AVAILPACK}\ZB dans le répertoire \Zbnoarch\ZB, catégorie \ZbSetup\ZB. Après être connecté à Internet, cliquer sur l'icône du bureau \Zbinstall\ZB pour lancer le Gestionnaire des Paquets, puis choisir le répertoire et la catégorie.


Remarque: Avant de télécharger le paquet, vous devrez établir une connexion Internet et utiliser le Gestionnaire des Paquets en anglais. Si vous ne comprenez pas l'anglais, l'alternative consiste à lancer avec un autre système d'exploitation, d'aller sur le site http://distro.ibiblio.org/quirky/pet_packages-noarch et télécharger le Langpack. Redémarrez Puppy, cliquez sur l'icône des partitions du bureau pour monter la partition (où est téléchargé le Langpack) et cliquez sur le fichier pour l'installer."



AVAILMSG="Les Langpacks officiels sont disponibles dans \Zbnoarch\ZB, mais il n'y en a pas pour votre langue. Peut-être y en a-t'il un en développement dans le forum (attention, certaines anciennes versions de Puppy possèdent des Langpacks incompatibles). Peut-être voulez-vous aider et/ou créer un Langpack - cliquez sur le menu -> Aide -> HOWTO internationalisation (vous devrez connaitre bien l'anglais)."



pupdialog --background '#8080FF' --colors --backtitle "Langpack nécessaire" --msgbox "La locale sera changée en ${LANGCHOICE}, mais vous devez installer un Langpack pour avoir Puppy dans votre langue. Vous avez besoin du paquet \Zblangpack_${LANG12}\ZB ou \Zblangpack_${LANG1}\ZB. Ce n'est pas encore automatisé, vous devrez donc télécharger et installer le paquet vous même. Vous pourrez le faire à n'importe quel moment plus tard. Les Langpacks bénéficiant d'un soutien officiel sont disponibles dans le Gestionnaire des Paquets (cliquez sur l'icône du bureau \Zbinstall\ZB ), et dans le répertoire \Zbnoarch\ZB.



${AVAILMSG}" 0 0



Posted on 13 Mar 2012, 21:12 by L18L
Quicksetup de translation 1
AVAILMSG="Es gibt ein passendes Sprachpaket \Zb${AVAILPACK}\ZB in der Kategorie \ZbSetup\ZB des PET-Repositoriums \Zbnoarch\ZB. Bei vorhandener Internetverbindung ein Klick auf das Symbol \Zbinstall\ZB auf dem Desktop und dann ein Klick auf Puppy Package Manager startet diesen. Im Paketmanager dann Kategorie Setup und Repo: puppy-noarch wählen.


Hinweis: Vor dem Herunterladen des Sprachpakets muß eine Internetverbindung hergestellt sein und der Puppy-Paket-Manager auf Englisch benutzt werden. Falls man glaubt, dies nicht auf Englisch hinzukriegen, kann man alternativ mit einem anderen Betriebssystem das langpack, Sprachpaket, herunterladen von http://distro.ibiblio.org/quirky/pet_packages-noarch. Dann Puppy hochfahren, ein Klick auf das Partitions-Symbol auf dem Desktop hängt die Partition ein, auf die das Sprachpaket heruntergeladen wurde und ein Klick auf das Sprachpaket-PET installiert es dann."


AVAILMSG="Offizielle langpacks, Sprachpakete, sind im Repositorium \Zbnoarch\ZB vefügbar, jedoch keines für deutsch. Vielleicht ist eines in Entwicklung im Puppy Forum (aber Achtung: einige ältere Puppy-Versionen haben inkompatible langpacks, Sprachpakete.). Oder "Do It Yourself": klick Menü -> Hilfe -> HOWTO Internationalization (you will of course need a good knowledge of English; und deshalb bleibt dieser Satz unübersetzt)."




Posted on 13 Mar 2012, 21:13 by L18L
Quicksetup de translation 2
pupdialog --background '#8080FF' --colors --backtitle "Sprachpaket erforderlich" --msgbox "Die locale wird geändert in ${LANGCHOICE}, aber es muß ein Sprachpaket installiert werden, um Puppy auf deutsch laufen zu lassen. Ein PET-Paket namens \Zblangpack_${LANG12}\ZB oder \Zblangpack_${LANG1}\ZB wird gebraucht. Wir habe dies noch nicht automatisiert, sodaß man das Paket noch selbst herunterladen und installieren muß, das ist auch irgendwann in der Zukunft noch möglich. Offiziell unterstützte langpacks, Sprachpakete, sind im Puppy Package Manager (Klick auf das Symbol \Zbinstall\ZB auf dem Desktop), im Repo: \Zbpuppy-noarch\ZB zu finden.


${AVAILMSG}" 0 0



Posted on 13 Mar 2012, 24:34 by rodin.s
Russian translation
I have made Russian translation.
I couldn't paste it here.


Posted on 14 Mar 2012, 6:28 by vicmz
Spanish update for QuickSetup
See the Wary/Racy feedback thread or click here for direct download


Posted on 14 Mar 2012, 8:26 by BarryK
QuickSetup hard-coded translations
Thanks guys, I have put these hard-coded translations into QuickSetup.

I think that this will improve the user experience for those who have difficulty with reading English. They will then know what they have to do to install the appropriate langpack asap.

Woof can now build a pup pre-set to a particular language, if the langpack is included in the pkg list. But, we haven't actually tested this yet. It will be interesting, we could have a lot of language-specific Puppies getting released.

When I release next Wary/Racy for example, it will be extremely simple for someone to do a build in Woof, with say, the 'langpack_de' and the Woof '3builddistro' script asks what LANG is to be preset to, so you enter "de_DE.UTF-8" -- and hey presto, a German Wary/Racy!



Posted on 14 Mar 2012, 17:02 by rodin.s
remastering
It would be nice to have remastering option rather then building in Woof. I guess current remastering program doesn't handle early boot messages and xz-compression.


Posted on 14 Mar 2012, 18:30 by BarryK
Re remastering
Remastering should work ok. If you used QuickSetup to change the locale, you are offered to translate the initrd.gz file, and that can be used in the remaster. The initrd.gz file is gzipped only.



Posted on 15 Mar 2012, 4:16 by FlyingDutchman
Dutch translation
AVAILMSG="Er is een geschikt \Zb${AVAILPACK}\ZB pakket in de \Zbnoarch\ZB PET repository, in de \ZbSetup\ZB categorie. Klik op het \Zbinstall\ZB pictogram op het bureaublad om de Puppy Package Manager te starten en kies vervolgens de repository en categorie.


Opmerking: Voor het downloaden van het taalpakket is een werkende internetverbinding nodig. Tevens moet de Puppy Package Manager in het Engels worden gebruikt. Als u Engels hiervoor onvoldoende beheerst is het ook mogelijk om vanuit een ander besturingssysteem naar http://distro.ibiblio.org/quirky/pet_packages-noarch te gaan en het taalpakket (langpack_nl) te downloaden. Start daarna Puppy op, klik op het pictogram van de partitie waarop het taalpakket is opgeslagen en klik vervolgens op de taalpakket PET om het te installeren.



AVAILMSG="Er zijn officiële taalpakketten beschikbaar in de \Zbnoarch\ZB repository maar helaas is er geen taalpakket gevonden voor uw taal. Wellicht wordt er aan een vertaling gewerkt in het Puppy Forum (pas op, sommige oudere Puppy versies gebruiken taalpakketten die niet uitwisselbaar zijn). Of misschien wilt u helpen bij het creëren van een taalpakket -- Klik Menu -> Help -> HOWTO Internationalization (U hebt hiervoor uiteraard een goede kennis van het Engels voor nodig)."



pupdialog --background '#8080FF' --colors --backtitle "Taalpakket nodig" --msgbox "De standaard taal wordt gewijzigd naar ${LANGCHOICE}, maar u moet een taalpakket installeren om Puppy in uw taal te vertalen. U hebt daarvoor een PET pakket nodig met de naam \Zblangpack_${LANG12}\ZB of \Zblangpack_${LANG1}\ZB. We hebben dit nog niet geautomatiseerd dus u zult dit zelf moeten downloaden en installeren. U kunt dit op elk gewenst moment doen. Officeel ondersteunde taalpakketten zijn beschikbaar door het de Puppy Package Manager te starten (klik op het \Zbinstall\ZB pictogram op het bureaublad), in de \Zbnoarch\ZB repository.


Tnx so much 4 PL!


Posted on 15 Mar 2012, 8:16 by BarryK
Re nl mini-translation
FlyingDutchman,
Thanks very much, I have put your translation into the script.



Posted on 15 Mar 2012, 8:16 by vicmz
Portuguese, Italian and Spanish
here


Posted on 15 Mar 2012, 13:32 by BarryK
Re pt, es, it
vicmz,
Fantastic! I have added them too.



Posted on 30 Jun 2012, 24:06 by FlyingDutchman
Re nl mini-translation
Barry, I just saw my Dutch mini translation in action for the first time(in Racy 5.3) and noticed to my embarrassment that it contains a small error: Basically there's one 'the' too many. My apologies for that. Good thing I'm not a programmer..

Here's the corrected translation:

AVAILMSG="Er is een geschikt \Zb${AVAILPACK}\ZB pakket in de \Zbnoarch\ZB PET repository, in de \ZbSetup\ZB categorie. Klik op het \Zbinstall\ZB pictogram op het bureaublad om de Puppy Package Manager te starten en kies vervolgens de repository en categorie.




Opmerking: Voor het downloaden van het taalpakket is een werkende internetverbinding nodig. Tevens moet de Puppy Package Manager in het Engels worden gebruikt. Als u Engels hiervoor onvoldoende beheerst is het ook mogelijk om vanuit een ander besturingssysteem naar http://distro.ibiblio.org/quirky/pet_packages-noarch te gaan en het taalpakket (langpack_nl) te downloaden. Start daarna Puppy op, klik op het pictogram van de partitie waarop het taalpakket is opgeslagen en klik vervolgens op de taalpakket PET om het te installeren.







AVAILMSG="Er zijn officiële taalpakketten beschikbaar in de \Zbnoarch\ZB repository maar helaas is er geen taalpakket gevonden voor uw taal. Wellicht wordt er aan een vertaling gewerkt in het Puppy Forum (pas op, sommige oudere Puppy versies gebruiken taalpakketten die niet uitwisselbaar zijn). Of misschien wilt u helpen bij het creëren van een taalpakket -- Klik Menu -> Help -> HOWTO Internationalization (U hebt hiervoor uiteraard een goede kennis van het Engels voor nodig)."







pupdialog --background '#8080FF' --colors --backtitle "Taalpakket nodig" --msgbox "De standaard taal wordt gewijzigd naar ${LANGCHOICE}, maar u moet een taalpakket installeren om Puppy in uw taal te vertalen. U hebt daarvoor een PET pakket nodig met de naam \Zblangpack_${LANG12}\ZB of \Zblangpack_${LANG1}\ZB. We hebben dit nog niet geautomatiseerd dus u zult dit zelf moeten downloaden en installeren. U kunt dit op elk gewenst moment doen. Officeel ondersteunde taalpakketten zijn beschikbaar door de Puppy Package Manager te starten (klik op het \Zbinstall\ZB pictogram op het bureaublad), in de \Zbnoarch\ZB repository.



Posted on 31 Jun 2012, 8:28 by BarryK
re nl mini-translation
FlyingDutchman,
Thanks, applied the fix.