Precise Puppy alpha2

This is working great, using it right now!

Download from here:

Previous announcement, for alpha1:

There is one known issue:
ePDFView does not work, is missing. To get this, run the Puppy Package Manager, choose the "ubuntu-main" repository, then type "liblcms2" into the search box.

Forum thread for feedback:

Posted on 26 Mar 2012, 21:32


Posted on 27 Mar 2012, 2:45 by Terryphi
OSMO dependencies
Can you please add missing libraries needed by Osmo in next build? Osmo complains about missing and (and maybe more.)

Also, Leafpad is missing icon in menu.

Posted on 27 Mar 2012, 7:29 by BarryK
Osmo deps
Aaargh! Osmo can be precompile-configured to use either libgtkhtml (very small) or webkit (huge) to render HTML pages. Unfortunately, Ubuntu has chosen the latter.

So, I have changed the Precise Puppy build to use one of my PETs.

Note, I already had to do this for Abiword (use a PET), for the same reason, huge deps.

Posted on 27 Mar 2012, 7:36 by BarryK
Helpsurfer HTML viewer
As I have added libgtkhtml, needed by my Osmo PET, I have also added helpsurfer, a very small HTML viewer, that also uses libgtkhtml.

Posted on 27 Mar 2012, 7:40 by BarryK
Here is my earlier blog post introducing Helpsurfer:

Posted on 27 Mar 2012, 13:32 by pemasu
More inspection in murga-thread

And the posts after that. There is also one important post about the 3.2.X kernel.

Posted on 9 Apr 2012, 4:17 by leae89
Download speed is getting slower
Yes; I'm having speed issues whilst downloading Puppy from I tried downloading from another server, and I get the same speed issue.
Are the servers going down?

Posted on 9 Apr 2012, 4:18 by leae89
Or is it a problem of my ISP DNS servers?