Schedule for Wary/Racy 5.3

I was planning to release Wary/Racy 5.3 toward the end of this week. Then a serious bug in Unionfs emerged, see post yesterday:
http://bkhome.org/blog/?viewDetailed=02777

Aufs
So, I am going to change the kernels over to using Aufs. This means that there will have to be an RC3, but I am still going to target near-end-of-week to release 5.3-final.

There is going to be tester burnout if I drag this on much longer. So, 5.3 is coming very soon! I am even toying with the idea of taking a bigger risk and not releasing RC3, just test it myself, and go straight for the final.

After all, we have plenty puppies that use Aufs without much trouble. Wary, with 2.6.32.x kernel, will have to use an older version of Aufs, as the developers stopped supporting that kernel 8 months ago. However Racy will have the latest Aufs3, which does introduce the possibility of some new bug.

Note, I have already compiled these kernels and will upload the PETs and sources soon. Wary will have 2.6.32.59 and Racy will have 3.0.25.

Adobe Flash
A note about the Adobe Flash Player, Woof has code (in /usr/sbin/delayedrun) that offers to download the Flash Player after an Internet connection is detected.
Unfortunately, there are many reports of the latest Flash Player not working on older CPUs, even not-so-old CPUs.

So, I plan to create a PET package and that will be installed. I have feedback that 11.1.102.63 works ok -- is there already a PET of this version? -- does anyone know what URL to download this version from? I even wonder, there are some 10.x versions PETs in the repos, is 10.x too old?

Langpacks
If any of the translators would like to provide an updated langpack, today is the deadline, as I intend to build RC3 (which could become 5.3-final) several hours from now.
These are the ones I currently have:

langpack_de-20120325
langpack_es-20120328
langpack_fr-20120330
langpack_pl-20120327
langpack_ru-20120318



Posted on 3 Apr 2012, 8:55


Comments:

Posted on 3 Apr 2012, 8:16 by BarryK
Flashplayer 10.0.15.3
I notice that the T2 repo is still using Flashplayer 10.0.15.3:
http://t2-project.org/packages/flashplayer.html

We have a PET of this. Or, this later one:
http://distro.ibiblio.org/quirky/pet_packages-common/flashplayer10-10.0.42.34.pet

Maybe I will change delayedrun to install this.

Anyone interested, give that old player a spin, let me know how it works!



Posted on 3 Apr 2012, 8:21 by james c
Adobe link
I used the link for 11.1.102.63 for all those Wget tests. Link is
http://fpdownload.macromedia.com/get/flashplayer/pdc/11.1.102.63/install_flash_player_11_linux.i386.tar.gz


Posted on 3 Apr 2012, 9:15 by BarryK
11.1.102.63
james c,
Thanks for that, I have put that url into delayedrun script.

In future, the code should be enhanced to offer a choice, even offer to download flashplayer v9 for i486/i586 CPUs.



Posted on 3 Apr 2012, 9:37 by Ramachandran
Flash
Dear Sir

getflash-0.9.pet
http://shino.pos.to/linux/puppy/

I have used this. Got the flash.


Posted on 3 Apr 2012, 12:17 by bigpup
What Flash player?
I have gone to websites where the video would not play, because I did not have a newer version of Flash player. So, locking in to an older version may be a problem in the future. Seems some websites want the most up to date version. Probably for security reasons.


Posted on 3 Apr 2012, 12:25 by bigpup
Example required Flash Player
From YouTube help

Flash

All videos on YouTube are streamed through Adobe Flash Player. Flash is a plug-in for your web browser, and like most software, is updated periodically by Adobe. To ensure smooth playback when watching YouTube videos, you'll need to ensure you have the most updated version of Adobe Flash.


Posted on 3 Apr 2012, 13:22 by Sage
FlashPlayer
It's nothing l;ike as simple as suggested above! There has been extensive discussion on many Forum threads. mick01 has the best handle on things. You need a different version for different browsers and different releases for different browser releases. To add to the confusion, Adobe has been shuffling their URLs recently, so a lot of links from earlier Puppies (and other distros) point to empty space.
Generally, you have to know or know someone who knows, or use the Adobe website, select 'other Linux' for a tarball and follow mick01's formula for extracting and shifting files around(which many non-coders promptly forget).
Can o' worms................


Posted on 3 Apr 2012, 13:32 by xman
Patched versions
Adobe has two patched flash players. For users who cannot update to Flash Player 11.2.202.228, Adobe has developed a patched version of Flash Player 10.3, Flash Player 10.3.183.18: http://www.adobe.com/support/security/bulletins/apsb12-07.html.

11.2.202.228 is too heavy for some old puppy linux machines, tested. It generates heat in some new puppy linux machines, maybe. Certainly, a pet of 10.3.183.18 is on someones wish list.


Posted on 3 Apr 2012, 13:36 by Terryphi
2 flash versions
Versions 11.2.202.228 and 11.1.102.63 both need to be available as pet options in Racy and Wary. This should cover the needs of newer and older hardware.


Posted on 3 Apr 2012, 13:42 by bigpup
GetFlash
So far for me, this program has worked for finding and installing the latest Flash Player.
GetFlash 0.9
http://www.murga-linux.com/puppy/viewtopic.php?t=74491

I agree with Sage. Adobe Flash Player is a BIG CAN OF WORMS!


Posted on 3 Apr 2012, 14:13 by Terryphi
Flash 10.3.183.18 looks promising
Flashplayer: I have just started testing the security patched version 10.3.183.18 for older hardware which cannot run 10.2.202.228. It looks good so far. (11.1.102.63 should not be used because of vulnerability.)


Posted on 3 Apr 2012, 14:31 by Terryphi
AMD Athlon flash solved
The problem with AMD Athlon is solved using flashplayer 10.3.183.18. I will create a pet for wider testing later.


Posted on 3 Apr 2012, 15:44 by Terryphi
PET Flash-player 10.3.183.18.pet
I have created a pet for Flashplayer 10.3.183.18 and I would appreciate it if you would test it on your hardware. It is intended for hardware which will not run version 11.2.202.228.


Full details in this forum thread:

http://www.murga-linux.com/puppy/viewtopic.php?p=616867#616867


Posted on 3 Apr 2012, 15:57 by rodin.s
Russian langpack
I have updated Russian langpack. mo files for scripts with yes and no was updated.


Posted on 3 Apr 2012, 16:19 by esmourguit
Aufs
Do you plan to update /etc/rc.d/rc.update using Aufs instead of Unionfs.

langpack_fr-20120330 is the last good one


Posted on 3 Apr 2012, 17:04 by Terryphi
flash-player-11.2.202.228.pet
While I was in pet making mode I also created a pet for Flashplayer 11.2.202.228. Details are in this forum thread:

http://www.murga-linux.com/puppy/viewtopic.php?t=77257

However, as 10.3.183.18 is also security patched that version may be the best default version for Puppy on a range of hardware.


Posted on 3 Apr 2012, 17:33 by Sage
FlashPlayer
I suppose that we need a list showing which FP is required for
Wary
Racy
Saluki
old AMD
new AMD
Intel
SM
Opera
Midori
Intel video
nV
ATI
...perm. any combo from above!
Arduous as it might seem and yet another burden, the obvious answer would be to ask developers to supply the appropriate version for the release they offer. PD & mick01 tend to achieve this by iteration and requests, mostly.



Posted on 3 Apr 2012, 18:00 by Terryphi
Flash compatibility testing
Sage,

I have tested my flash-player-10.3.183.18.pet and comparing with your checklist I can confirm it works with Wary, Racy, old AMD, Intel, SM, Opera and Intel video.

If it works in Racy I assume it works in Saluki. I do not have any of the other stuff so can you test if you have it to hand?


Posted on 3 Apr 2012, 18:50 by Sage
FP compat. testing
Only 'difficult' system I can lay hands on easily today was my trusty 754 with the SiS Mirage I chipset. Used Saluki v17 liveCD. A killer combo if ever. This managed to break your 10.3.183.18.pet ! Mind you, it was a good guess that it would, based on previous experience.
The worms get it....


Posted on 3 Apr 2012, 19:06 by Sage
FP compat. testing
Addendum: that was Midori & Opera11.61


Posted on 3 Apr 2012, 19:20 by Sage
FP compat. testing
Yep - every time it's PD that gets it right! Lucid 5.2.8 on above system, boots into correct res. (none of the others do), d/l Opera11.61, install your 10.3.183.18.pet - instant success!
As you know, some of the devs around here like to ignore difficult systems I report and hope they will go away. But those who've stuck around longest know I possess a wide range of kit and that, apart from an occasional misunderstanding due to my non-coder status, my observations tend to turn out to be on the button.
Apart from the most competent, PD, along with mick01 tend to be the most responsive and courteous guys too - now there's a surprise!
Out for the rest of the day. Well done Terr-i.


Posted on 3 Apr 2012, 19:23 by scsijon
flashplayer 11
I've used your flashplayer_11.pet since it came out and although I have updated a few times with the latest and greatest, in each case i've had a problem somewhere and gone back to it.

I'm using ff11 on a number of various acers with a i915 video.


Posted on 3 Apr 2012, 19:40 by scottman
flash-get by techno
In Akita I am using Technos 'Flash-Get', which I have modified a bit, and it allows you to CHOOSE which version of Flash you want installed, and only 1 option always installs the latest.

It also has the added feature of being able to 'fake' upgrade any Flash version, so that it reports itself to browsers as 10.3 or whatever...

I have never had Flash issues in any browser, mainly cos I can mix and match Flash versions to suit my needs..

People should look at Flash-Get by techno :D

(It does still include the fairly major bug that shinobar recently fixed, regarding Adobe tarballs changing the owner/group on /usr,/usr/bin,/usr/lib,/usr/share )


Posted on 3 Apr 2012, 20:02 by 01micko
FL:ASH IS DEAD
Latest seamonkeys/firefoxes/chromes/(operas?) all work on youtube with html5. (recent slacko beta-2 has compiled seamonkey-2.8 and it works, using an IBM thinkpad r51 on battery, cpu scaled back to 600MHz, 512 RAM, radeon mobility 7200 graphics as a test bed).

I suggest forgetting adobe flash and looking forward.. sure add pets for the ones who need, add an installer too, but forget flash as a default in /usr/sbin/delayedrun. Shinobar's installer is good and light.

Get over flash folks, it's never been any good since the macromedia days anyway.


Posted on 3 Apr 2012, 20:19 by Terryphi
Still need flash
Like 01micko I look forward to a time when we can do without flash. Unfortunately, that day has not yet arrived.

Many sites are not yet compatible with html5. That includes the popular BBC News site .




Posted on 3 Apr 2012, 21:27 by dogle
Don't need Flash
I haven't used Phlash in years ... so I'm very glad that it isn't there by default, it was tiresome having to delete the rotten thing from earlier Pups.

If there really is need for a PET, OK, but to build in an automatic prompt to download commercial nastyware is getting far, far too close to that very widely used, but markedly inferior, OS ....IMHO.

(01micko, well said).


Posted on 3 Apr 2012, 22:22 by L18L
langpack de
uploaded to
Omp. Not for Everyone.
langpack_de-20120403.pet

/usr/share/Abiword-2.8/strings/ and some files had to be inserted manually, was not done by momanager.


Posted on 3 Apr 2012, 24:32 by Sage
Don't need Flash
Oh yes we do!
This all dates back to the time Blair was hood-winked by Billy Boy. Balir admitted on-air that he didn't know how to switch on a PC. Billzebub hijacked a public meeting to promote XP and Blair gave him an honourary knighthood. Although, Auntie is nominally outside political influence, everybody in Blighty knows this to be a lie. As a result She is tied into a dud OS and all the other capitalist proprietary cr*p. Terr-i is correct; for punters in GB who have already paid their TV license, sadly it isn't possible to "Get over flash folks". At least, not for the moment. Frankly, we'd probably be better off technically if a Russian oligarch took over the Beeb. So there you go, it's Flash or nothing...


Posted on 4 Apr 2012, 9:02 by ozsouth
More sites needing 11.x
I'm finding an increasing number of sites needing flash 11.x, i.e. abc.net.au - flash 10.3 is no go.


Posted on 4 Apr 2012, 15:01 by Terryphi
Flash at abc.net.au
ozsouth: flashplayer 10.3.183.18 works for me at abc.net.au just as well as 11.2.202.228 so the site does not require version 11. However, I have not tested the site on older hardware.


Posted on 4 Apr 2012, 16:52 by ozsouth
abc.net.au - Video News
Sorry I should have explained better - 1/3 of the way down the page is 'VIDEO News in 90 Seconds'. I get an error message with various puppies on various machines with Firefox 9.01 & Seamonkey 2.6.1, when using Flash 10.3, but fine with 11.2.


Posted on 4 Apr 2012, 22:26 by Terryphi
abc.net.au - Video News
ozsouth,

Yes, I see what you mean. It does not work for me either. I just tested a video on the home page which did work.

Fortunately, no major website here in the UK requires Flashplayer 11 (yet!). If it becomes widespread it will create a big problem for Linux users with old hardware which will not run 11.2.202.228. Adobe says 11.1.102.63 and earlier are insecure. (10.3.183.18 is a new security patched build.)