Xarchive internationalised

I announced support for .rar archive files in Puppy, and we were discussing Xarchive. L18L had reported that the C source is not internationalised, and rodin.s took up the challenge and did it:

Thanks very much! I have compiled the new internationalised Xarchive in Wary and uploaded the PET to the 'common' repo (38KB):

Note, I have not yet updated the ARM PET.

I uploaded the new source to my sources repo (xarchive-0.2.8-6-i18n.tar.gz):

For the convenience of creating translations with MoManager, I have placed the 'xarchive.pot' file into Woof, in rootfs-skeleton/usr/share/doc/nls/xarchive -- MoManager will automatically read this and offer it to be translated.

Woof commit:

I just remembered something. L18L and rodin.s, if you read this, kindly let me know: I think that you guys i18n'ed a couple of the tray apps?
I still have the non-translated versions in the 'common' PET repo. Would you mind posting the links to where you did this work? I will update those also.

Posted on 16 May 2012, 17:36


Posted on 16 May 2012, 19:54 by rodin.s
i18n tray apps
Here i18n-ed tray applets. I have changed it a little to match MoManager "one application - one pot file" policy.

Posted on 16 May 2012, 20:27 by L18L
my i18n tray apps
Sorry, none made by me, for now.
The only time I have touched a tray app was with pizzagood's retrovol making it working with non-UTF8 locales by


(UTF-8 test)

Posted on 18 May 2012, 23:38 by charlie6
Automount a USB flash drive
Hi Barry,
(here tested on Dpup-Exprimo 5X.3.2.14 fresh pristine session):
automount now works using the later drive_all script.
Now clicking on a drive icon does not longer open Rox. It starts Pmount instead.
Rather slower especially on this exprimo which scans all the partition (ca. 1-2 sec./partition) before displaying the Pmount box. Only then the partiton may be (un)mounted and rox-opened.

If back to /Menu/System/PupEventManager/iconHandler and uncheck the automount box + restart X, then all get back as before installing the new drive_all.

Is there another PupEventSetting to get also rox to open upon mouse-click on a drive icon?

Cheers !

Posted on 19 May 2012, 9:12 by BarryK
Automount works
I have just tested it, it works correctly.

I am running Racy 5.3, with the latest drive_all.

With automount enabled, I plug in a usb flash drive and it automatically mounts and ROX-Filer window opens.

If I then click on the partition icon, another ROX window opens. I do not get Pmount running.

Did you use the latest drive_all script that I uploaded? I reported a syntax error a day or so ago, see the appropriate blog thread.

Posted on 19 May 2012, 19:08 by charlie6
Automount works
Hi Barry,
Ooops...!I indeed was using the wrong version.
I promise not to do it again ...;-)
Thanks again!