Woof commit 19ad701efd

This is the Woof used to build Squeezed Arm Puppy alpha3 for the Raspberry Pi.

Woof commit:
http://bkhome.org/fossil/woof2.cgi/info/19ad701efd

Note that sap6 alpha3 was built with an SD-card skeleton image dated 09-July-2012, I will upload that now.


Posted on 11 Jul 2012, 18:49


Comments:

Posted on 13 Jul 2012, 20:05 by 01micko
whezzy changes
Hi Barry,

I don't know if you are aware but debian-wheezy have changed their database format. I fixed it (please check).

Diff:
--- 0setup.orig	2012-07-13 15:24:27.928043805 +1000

+++ 0setup 2012-07-13 21:56:06.152539140 +1000
@@ -303,11 +303,16 @@
echo -n "" > $ONE_PKGLISTS_COMPAT
case ${DISTRO_BINARY_COMPAT} in
ubuntu|debian)
+ if [ "$DISTRO_COMPAT_VERSION" = "wheezy" ];then #120713 wheezy has changed the DB format!
+ CASE_VAR='Filename*'
+ else
+ CASE_VAR='Description*'
+ fi
while read DB_ONELINE
do
eval $DB_ONELINE
case $DB_ONELINE in
- Description*)
+ $CASE_VAR)
DB_fullfilename="`echo -n "$Filename" | rev | cut -f 1 -d '/' | rev`"
DB_path="`echo -n "$Filename" | rev | cut -f 2-9 -d '/' | rev`"
DB_version="`echo -n "$Version" | sed -e 's%^[0-9]:%%' -e "$v1PATTERN" -e "$v2PATTERN"`"


Don't know if they changed it for earlier versions, I guess not, pemasu would be on to it.


Posted on 13 Jul 2012, 20:47 by BarryK
Re DB change
We are going to have to double-check this. Ubuntu Precise is built from Debian Unstable, which is what I thought will become Debian Wheezy.
I did not have any problem with the conversion for Ubuntu Precise Pangolin.



Posted on 13 Jul 2012, 21:05 by 01micko
re DB
The if statement I have in there only affects wheezy, where the database is very different (this is arm though). Will have to check x86. With the "Description*" var I get garbage, with the fix it works, running 1download right now, and it's chugging along nicely.

Here's where I 'm getting the DB's
http://http.us.debian.org/debian/dists/${DISTRO_COMPAT_VERSION}/main/binary-armel/Packages.bz2

DISTRO_COMPAT_VERSION=wheezy


Posted on 13 Jul 2012, 21:14 by 01micko
i386 wheezy is different too
I just grabbed the i386 Packages.bz2 file and it'as the same as the armel version.
Package: 0ad

Version: 0~r11863-2
Installed-Size: 7745
Maintainer: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Architecture: i386
Depends: 0ad-data (>= 0~r11863), 0ad-data (<= 0~r11863-2), gamin | fam, libboost-signals1.49.0 (>= 1.49.0-1), libc6 (>= 2.11), libcurl3-gnutls (>= 7.16.2), libenet1a, libgamin0 | libfam0, libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libjpeg8 (>= 8c), libmozjs185-1.0 (>= 1.8.5-1.0.0+dfsg), libnvtt2, libopenal1, libpng12-0 (>= 1.2.13-4), libsdl1.2debian (>= 1.2.11), libstdc++6 (>= 4.6), libvorbisfile3 (>= 1.1.2), libwxbase2.8-0 (>= 2.8.12.1), libwxgtk2.8-0 (>= 2.8.12.1), libx11-6, libxcursor1 (>> 1.1.2), libxml2 (>= 2.7.4), zlib1g (>= 1:1.2.0)
Pre-Depends: dpkg (>= 1.15.6~)
Description: Real-time strategy game of ancient warfare
Homepage: http://www.wildfiregames.com/0ad/
Description-md5: d943033bedada21853d2ae54a2578a7b
Tag: game::strategy, implemented-in::c++, interface::x11, role::program,
uitoolkit::sdl, uitoolkit::wxwidgets, use::gameplaying,
x11::application
Section: games
Priority: optional
Filename: pool/main/0/0ad/0ad_0~r11863-2_i386.deb
Size: 2226038
MD5sum: 93699f007bcd8a51e1ab5fba2ecdc400
SHA1: 602e20176706d3cc7535f01ffdbe91b270ae5012
SHA256: 2b092f5682ae14351d6f7e47a7c113b7c0cc9ec71046a2e3ecf95eb453909ad8

That's the first entry, quite different. I wonder why the change? Size perhaps? The description is much smaller.