CUPS 1.4.8

I have compiled CUPS 1.4.8 in Wary, for use in Wary and Racy. This is to fix a problem with landscape printing, mentioned here:
http://bkhome.org/blog/?viewDetailed=02940

The PETs (2.2MB, 35KB, 603KB, 589KB):
http://distro.ibiblio.org/quirky/pet_packages-wary5/cups-1.4.8-w5c.pet
http://distro.ibiblio.org/quirky/pet_packages-wary5/cups_DEV-1.4.8-w5c.pet
http://distro.ibiblio.org/quirky/pet_packages-wary5/cups_DOC-1.4.8-w5c.pet
http://distro.ibiblio.org/quirky/pet_packages-wary5/cups_NLS-1.4.8-w5c.pet

Note that the PET package for 1.3.11, as used in Wary/Racy up until now, is 1.3MB, this new PET is 2.2MB.

Here is how I configured it:
# LDFLAGS='-L/usr/X11R7' DSOFLAGS='-L/usr/X11R7' CPPFLAGS='-I/usr/X11R7/include' CFLAGS='-I/usr/X11R7/include'  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-dbus --disable-pam --enable-libpaper --disable-ldap --disable-dnssd --disable-launchd --disable-slp  --disable-gssapi --disable-use-network-default --disable-pap --enable-openssl --disable-libusb --with-pdftops=/usr/bin/pdftops


...this took me awhile to get right. The '--disable-libusb' is required so that CUPS will use the old "usblp kernel module" method -- otherwise, the 'usblp' module has to be blacklisted. Besides, I'm not sure if the CUPS developers have got the new "libusb" method fully sorted out.


Posted on 6 Aug 2012, 11:27


Comments:

Posted on 6 Aug 2012, 14:33 by Terryphi
localhost cookie
Thanks for that Barry.

One point to note is that this version needs to set a cookie for localhost. It is impossible to add a printer if cookies are not allowed.


Posted on 6 Aug 2012, 20:37 by L18L
CUPS templates
Localizing CUPS needs /usr/share/cups/templates/<language>

AND !!!

a localized browser (see http://www.murga-linux.com/puppy/viewtopic.php?p=632184)

PS: I am a bit helpless at the moment which version to put into langpack or if more than 1 version how to get the right version....






Posted on 16 Aug 2012, 15:22 by L18L
CUPS versions
Racy 5.3

# cups-config --version
1.3.11
#

Installed cups-1.4.8-w5c.pet in fresh racy 5.3

# cups-config --version
1.3.11
#

There is no /usr/bin/cups-config in the pet so display of version is not correct.

(I am planning to put several versions of cups/templates/de/ into the langpack, which should fit all official puppies)



Posted on 16 Aug 2012, 16:43 by L18L
CUPS versions 2
No more helpless now

got correct version from
# grep CUPS /usr/share/cups/templates/header.tmpl | cut -d'<' -f2 | cut -d ' ' -f4

1.4.8
#



Posted on 16 Aug 2012, 19:57 by L18L
CUPS versions 3
After installing cups-1.4.8_DOC.pet I have found:

cups_NLS.pet must contain
- usr/share/cups/templates/
- usr/share/doc/cups/
- cups_xx.po is NOT needed

# cups-config --version
1.3.11
#
# grep CUPS /usr/share/cups/templates/header.tmpl | cut -d'<' -f2 | cut -d ' ' -f4
1.4.8
#

See an image at the forum:
http://www.murga-linux.com/puppy/viewtopic.php?t=76368&start=75








Posted on 17 Aug 2012, 4:11 by BarryK
cups-config
cups-config should be in the cups_DEV package.