PPM: dependencies fix

This bug has been there forever, good to finally fix it!

Precise Puppy is built with a 'cups' PET rather than the Ubuntu DEBs. As per normal, Ubuntu split a package into many DEBs, and cups becomes several, including 'libcups2'.

I noticed 'libcups2' showing up as a missing dependency when I was going to install 'gnome-control-center'. That is wrong, as the 'cups' PET is already installed.

If the 'libcups2' DEB was installed, it might cause problems as might not be compatible with the rest of the 'cups' PET.

I have fixed this problem. These "false dependencies" no longer show up. I modified scripts pkg_chooser.sh and findmissingpkgs.sh in /usr/local/petget.

This fix will apply to Puppy builds from Debian, Ubuntu and Raspbian DEBs.

Woof commit:
http://bkhome.org/fossil/woof2.cgi/info/8ec06c1cb7


Posted on 22 Aug 2012, 22:57


No comments posted yet.