Precise Puppy 5.2.73 (beta4)

Here is the third variant. The brothers were released today and yesterday:
5.2.72: http://bkhome.org/blog/?viewDetailed=02975
5.2.71: http://bkhome.org/blog/?viewDetailed=02974

5.2.73 is the same, except that I used Ubuntu 'mesa' DEBs (not all of them) instead of my 'mesa' PET. Some notes:
http://distro.ibiblio.org/quirky/test/precise-5.2.73/precise-5.2.73-readme.htm

Download:
http://distro.ibiblio.org/quirky/test/precise-5.2.73/

This one is the most "Ubuntu standard", so preferred from the compatibility viewpoint. Ubuntu splits the original 'mesa' package into about 26 DEBs (although I am not sure if all of them are taken out of the original mesa pkg). These are some that I did not include in the build:

libegl1-mesa-drivers
libegl1-mesa
libegl1-mesa-dev
libgbm1
libgbm1-dev
libgl1-mesa-swx11
libgl1-mesa-swx11-dev
libgles1-mesa
libgles1-mesa-dev
libgles2-mesa
libgles2-mesa-dev
libopenvg1-mesa
libopenvg1-mesa-dev
libosmesa6
libosmesa6-dev
libxatracker1
libxatracker-dev


This is what I did include:

libglapi-mesa
mesa-common-dev
libgl1-mesa-dri
libgl1-mesa-glx
libgl1-mesa-dev
libglu1-mesa
libglu1-mesa-dev
libglapi-mesa
mesa-utils


I don't know if I included enough mesa DEBs, but it is running ok with my Intel video -- though I note neither the i915_dri.so nor swrast_dri.so modules have loaded.
'libGL.so*' is being provided by 'libgl1-mesa-glx' DEB, but note that alternative libGL files are in 'libgl1-mesa-swx11' DEB. I don't know what the difference is.


Posted on 30 Aug 2012, 17:03


Comments:

Posted on 30 Aug 2012, 16:02 by 01micko
5.2.73
I reckon I can't tell the difference between this and 5.2.72, exactly the same on my cedar radeon, see forum report for 5.2.72 (next post fter 5.2.72 announcement) and the report would be identical.
Gaming is working quite well.


Posted on 30 Aug 2012, 16:03 by BarryK
5.2.73 feedback
Forum feedback:

http://murga-linux.com/puppy/viewtopic.php?p=649440#649440



Posted on 30 Aug 2012, 16:40 by Sage
5.7.3
Same as mick, almost. Seems to work as well as 71, even on old junk. No CUPS, no video issues.


Posted on 3 Sep 2012, 14:33 by aarf
precise fail on asus 1025c
precise 5.2.73 grub booted manual frugal
probably the wrong iso but anyhow the behavior was as reported by me on the precise thread in puppy forum.
grey screens after/while "loading kernel modules"
using a pupsave that was good in a previous precise, no messages were written to var/log and /tmp was not created.
tried both pfix=ram and also with the previously good pupsave in/from my previous equipment.
hardinfo output on asus 1025c at http://www.datafilehost.com/download-3b98540f.html (mostly the same except for lupu528.004 which says that it runs faster)
(quickpet lupu528.004 asus 1025c says "For your Intel video card, Intel Corporation Cedarview Integrated Graphics Controller (rev 09) we think the best add on driver is Xorg_High".)

have running on asus1025c saluki023 racy522 lupu528.004, quirks 100, 120, 140, fluppy 12&13, puppy301. so this problem is in precise only so far.


Posted on 3 Sep 2012, 15:32 by BarryK
re asus 1025c
aarf,
One small thing to check. Type "lsmod" in a terminal, and see whether "i915" or "i810" is loaded. If the latter, I don't think the the Intel Xorg driver will work, and you may have to run with the "vesa" driver -- but, I'm not sure about that. I'm not really up-to-date with the latest twists of this stuff.



Posted on 4 Sep 2012, 18:52 by aarf
lsmod precise pfix=nox,ram
precise 5.2.73 grub booted manual frugal pfix=ram,nox
no change. same greyscreen.

lsmod for lupu528.004 and racy522 athttp://www.datafilehost.com/download-7185ef34.html
cant see the ones mentioned above.


Posted on 4 Sep 2012, 19:37 by BarryK
Re asus intel
It does seem to be a kernel problem. It would be interesting to see if some other distro that uses the 3.2.x kernel, such as Ubuntu Precise Pangolin, has this problem.