Precise: Aqualung 20121029

I have compiled Aqualung music player in Precise Puppy 5.4. I got the source from SVN, 2012-10-29.

Aqualung project page:
http://aqualung.factorial.hu/

Configure options:
# ./autogen.sh
# ./configure --build=i486-pc-linux-gnu --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-jack=no --with-mod=no --with-mpc=no --with-mac=no --with-lua=no --disable-systray


I disabled the systray because a new instance starts in the tray every time a sound file is clicked-on in a ROX-Filer window.

PETs (343K, 333KB):
http://distro.ibiblio.org/quirky/pet_packages-precise/aqualung-20121029-up.pet
http://distro.ibiblio.org/quirky/pet_packages-precise/aqualung_NLS-20121029-i486.pet

Note, Aqualung is in the Ubuntu repo, but requires GTK3 and a lot more dependencies.


Posted on 29 Oct 2012, 10:44


Comments:

Posted on 29 Oct 2012, 10:47 by BarryK
Aqualung as default
Testers, you can set Aqualung as default, edit /usr/local/bin/defaultaudioplayer, change "pmusic" to "aqualung".



Posted on 29 Oct 2012, 14:19 by esmourguit
NLS problem
Hello Barry,
I installed your Aqualung's pet with NLS. I launched in console then it started in french, but when i launched it by the menu Multimedia it started in english!


Posted on 29 Oct 2012, 16:06 by technosaurus
aqualung dbus?
I seem to recall aqualung using dbus to detect a running instance. Of all the things it is bad about, many programs do use its ipc methods to hand control over to an already running instance. Libunique is the other that is smaller and widely used so it may be needed instead... its been too long.

BTW util-linux is gpl2 while binutils is gpl3 since 2.17+, so slackware is making their distro more useful.


Posted on 29 Oct 2012, 16:21 by BarryK
Re NLS problem
esmourguit,
I installed your Aqualung's pet with NLS. I launched in console then it started in french, but when i launched it by the menu Multimedia it started in english!

Oh, that is a weird one!

I can't think why that would be, if other apps run from the menu localised ok.

This may be something that our language experts might have to investigate!



Posted on 29 Oct 2012, 16:55 by esmourguit
NLS Problem following
BK said
Oh, that is a weird one!
I can't think why that would be, if other apps run from the menu localised ok.

You are right. No other app works in French if I start from the menu. While they all work if I start from the console ...
I had not noticed before for the other applications.
How strange!


Posted on 29 Oct 2012, 17:01 by esmourguit
NLS problem, Apologies
Sorry Barry,
I did not restart the X server after installing the french package. Please ignore my posts.