Precise: black desktop

Some Precise 5.4 testers have reported that on some boots they get a black desktop. As I understand it, the tray is there, but no desk-icons or wallpaper. This means that ROX-Filer has failed to start.

Unfortunately, no one who has this problem has experimented with various delays. Shinobar suggested this early in the Precise 5.4 Forum feedback thread, but there has been no response.

This makes it difficult for me. All that I can do is take a punt. There are three files where delays can be inserted or increased:

/root/.xinitrc
/sbin/pup_event_frontend_d
/usr/sbin/delayedrun


The last two scripts have "sleep 1", that I will now increase to "sleep 2" for the next build of Precise.


Posted on 5 Nov 2012, 23:54


Comments:

Posted on 5 Nov 2012, 24:15 by Paganini
Black Desktop
This has only happened to me once. I didn't even thought it was a big deal because i was messing with a lot of things, so i thought i was the one who caused it... Anyway, restarting X "fixed" it... it went back to normal.


Posted on 6 Nov 2012, 2:18 by drblock2
Precise black screen
Barry,

Sorry! I promised to try shinobar's fix and report back and did not follow through.

Increasing sleep from 1 to 4 at line 57 in /sbin/pupevent_frontend_d as he suggested solved the problem.


Posted on 6 Nov 2012, 3:14 by technosaurus
blackscreen
Some Xorg servers take several seconds to start so the sleep value may be too small, but there are a couple of alternatives to sleep:
for single displays add the equivalent
--display=:0 arg to apps that need and can use it
OR
export DISPLAY=:0
OR
tinycore has a little program called waitforx that is derived from xinit that loops through a nanosleep and getdisplay until the xserver is running.
OR
I wrote an alternative that loops looking for DISPLAY env var (no xlib required and makes a small dietlibc static app)


Posted on 6 Nov 2012, 3:51 by aarf
black screen
this is not my precise problem as mine doesnt get a bottom tray. in order to try this fix i would need a delta to alter the original iso. i have tried all the other suggestions at the forum thread except this one.


Posted on 6 Nov 2012, 4:46 by Ted Dog
Mouse LOCKUP
Are those the same files that affect the mouse lockup issue? if not where should I investigate? It also appears to be a timing issue.


Posted on 6 Nov 2012, 5:47 by rodin.s
I had this
I had this in earlier versions of Precise and Slacko but not in latest ones. I thought it was fixed.


Posted on 6 Nov 2012, 6:17 by FeodorF
Re: Black screen
I uploaded the process list and added it my post.

target=_blank>http://www.murga-linux.com/puppy/viewtopic.php?p=662213#662213


Regards Feodor


Posted on 6 Nov 2012, 7:38 by shiny
Re: Black screen
Re: Black screen

IBM ThinkPad x30
precise 5400 non-pae manual frugal

Works great first boot with NO save file,
but boots slowly, especially when getting
to the 'optical input'.

Doing a savefile and full powerdown,
precise starts every time, almost, failed once.

I have compiled apps and installed sfs, still ok.
Internet good. All good really.

Doing a RESTART it is always a black screen with NO tray.

I tried Shinobar's suggestion:
increasing sleep from 1 to 4
at line 57 in /sbin/pupevent_frontend_d
--AND--
that made booting from poweron much faster,
especially after the 'optical input'.

Still black screen on restart.

Never a problem with wary5300 or racy5300

Bill