Glipper internationalized

Vicmz posted internationalization changes for the 'glipper_shell' script in the 'glipper' PET.

I applied those changes, plus some more of my own:
#!/bin/sh

#Barry Kauler 2007
#130212 vicmz: internationalized.
#130212 BK: link in /root/Startup. removed code from /root/.xinitrc.

export TEXTDOMAIN=glipper_shell
export OUTPUT_CHARSET=UTF-8

Xdialog --center --title "$(gettext 'Glipper clipboard manager')" --ok-label "$(gettext 'Enable Glipper')" --cancel-label "$(gettext 'Disable Glipper')" --yesno "$(gettext 'Glipper is a great little taskbar applet for managing the clipboard.')

$(gettext "If you click the 'Enable Glipper' button, then Glipper will appear in
the takbar, and will also start automatically in the future.")
$(gettext "If you click the 'Disable Glipper' button, then if Glipper is runnng
it will be terminated now and will not be started in the future.")" 0 0

RETVAL=$?

if [ $RETVAL -eq 0 ];then
#touch /root/.glipper_on
ln -snf ../../usr/local/bin/glipper /root/Startup/glipper_tray
PSRUN="`ps`"
[ "`echo "$PSRUN" | grep -v 'glipper_shell' | grep 'glipper'`" = "" ] && /root/Startup/glipper_tray &
exit
fi

if [ $RETVAL -eq 1 ];then
#rm -f /root/.glipper_on
rm -f /root/Startup/glipper_tray
killall glipper
killall glipper_tray
exit
fi


Note to vicmz and L18L, single and double quotes can be nested, as per my code above.

PETs for x86 and ARM (15K, 14K):
http://distro.ibiblio.org/quirky/pet_packages-common/glipper-0.89-2-puppy4.pet
http://distro.ibiblio.org/quirky/arm/pet_packages-armv7/glipper-0.89-1-armv7.pet


Posted on 12 Feb 2013, 21:55


Comments:

Posted on 12 Feb 2013, 22:40 by L 18 L
re glipper
takbar should be taskbar
runnng should be running




Posted on 13 Feb 2013, 8:27 by vicmz
re gettext quotes
L18L does know that, I'm the clumsy guy ;-)


Posted on 13 Feb 2013, 8:56 by BarryK
Re glipper
And I'm blind!

Fixed it, also changed "taskbar" to "tray".

PETs re-uploaded.



Posted on 13 Feb 2013, 24:58 by L 18 L
Glipper ELF i18n
After glipper_shell now glipper

I have compiled glipper-0.95.1 (from your sources, latest versions are python scripts)

LIBS="-lXext -lX11"  ./configure --disable-gnome --x-libraries=/usr/lib


xgettext --keyword=_ -f po/POTFILES.in -o glipper.pot


+ internationalization works (de,fr and ru)
- 155 kB size

Hope you can (and will, please) produce a smaller binary.



Forum:
http://www.murga-linux.com/puppy/viewtopic.php?t=83672&start=5


Posted on 14 Feb 2013, 3:37 by L 18 L
glipper-lite
There are recent discussions and solutions in forum:
http://www.murga-linux.com/puppy/viewtopic.php?t=52235




Posted on 14 Feb 2013, 8:01 by vicmz
langpack_es-20130213
Not-so-off-topic, there is a new version of the Spanish langpack available:

https://www.dropbox.com/s/jqf6vw6u7lhirda/langpack_es-20130213.pet