Precise: deps bug

There is a bug in package dependencies, in the PPM, in Precise Puppy 5.4.92 (5.5beta).

I have just install 'guvcview' and its dependencies. The deps include 'libportaudio2', which in turn requires 'libasound21.0.24.1' -- but, that is an error, in the pup pkg db entry for libportaudio2, the dep is supposed to be 'libasound2&gt1.0.24.1', however, the "&gt" is missing.

The dep is supposed to be 'libasound2', version greater than '1.0.24.1'.

The original pkg data for 'libportaudio2' has this line for the deps:

Depends: libasound2 (>> 1.0.24.1), libc6 (>= 2.7), libjack-jackd2-0 (>= 1.9.5~dfsg-14) | libjack-0.116

I did not realise that ">>" means "greater than". An oversight.
I have fixed 'debdb2pupdb.bac' in Woof and will recompile for x86 and ARM, and upload Woof soon.


Posted on 21 Feb 2013, 4:09


No comments posted yet.