vercmp failure fix

Broomdodger discovered a problem with deps for 'phantomjs' in Precise pup. The problem was a version comparison in /usr/local/petget/, like this:

if vercmp 2.2.1 ge 2.2~2011week36; then echo 'greater'; fi

The intention is that 2.2.1 is greater than 2.2, however that is not what vercmp thinks.

I have worked around this by modifying support/debdb2pupdb.bac in Woof to remove any '~' character and anything past it.
Of course, that means we won't be able to distinguish between say "2.2~2011week36" and "2.2~2011week37", but I'll live with that, as it is a very unlikely scenario.

I haven't actually tested this change. I have compiled debdb2pupdb.bac for x86 and ARM, next have to do a Precise build from ./0setup, to make sure it works as intended.

Woof commit:

Posted on 11 May 2013, 19:55


Posted on 11 May 2013, 21:35 by Jades
Test post
'Jades' has registered.

Posted on 11 May 2013, 23:06 by don570
mhwaveedit + ladspa

I compiled mhwaveedit in latest precise beta
so that ladspa effects can be applied in the
program. It's available if you want to include it. It is stripped and a useful configuration
file is added.

and here is the locales