Precise 5.6.9 (5.7beta1)

Uploaded here:
http://distro.ibiblio.org/quirky/test/precise-5.6.9/

This build has two web browsers, SeaMonkey and QtWeb.

QtWeb
There is a bug with running QtWeb as user spot. If you run the Login and Security Manager (System menu) to change QtWeb to run as spot (this is also offered in QuickSetup), just before actually launching QtWeb, change the name of this file:

/root/spot/.config//QtWeb.NET/"QtWeb Internet Browser.ini" to "QtWeb Internet Browser.conf".

mesa
As an experiment I have gone back to the official Ubuntu mesa and llvm DEBs, instead of the mesa PET that I had compiled without llvm dependency (which is in 5.6.4).

Some testers were reporting very low frames per second with 'glxgears', and I want to see if this makes any difference.

.iso size
It is 198MB. That's because it has the analog modem drivers, and the two web browsers, but mostly because the .sfs file is gz'ed, not xz'ed -- be sure not to compare apples with oranges when comparing size with some other pups that use xz.
If I go back to my mesa PET, that size will drop by several MB.


Posted on 21 Jul 2013, 19:21


Comments:

Posted on 21 Jul 2013, 21:29 by BarryK
QtWeb as root
Oh, the default config file for QtWeb, that I put into the PET:

/root/QtWebSettings/QtWeb.NET/QtWeb Internet Browser.ini

is wrong. It needs to be moved, and renamed:

/root/.config/QtWeb.NET/QtWeb Internet Browser.conf

This change, similar for running as spot, came about because I initially setup QtWeb without that 'unins000.exe' file that jamesbond told me about.



Posted on 21 Jul 2013, 21:59 by aarf
webseeded torrent Precise 5.6.9
http://www1.datafilehost.com/d/0eced285
or
https://www.mydrive.ch/download/251954150/precise-5.6.9.iso.torrent

need to use login: puppy@changed
password: linux1

use transmission and the webseeds will give you the fastest download possible and approximately nothing will upload in return.

full blackscreen


Posted on 21 Jul 2013, 23:46 by Terryphi
QtWeb as root
Contrary to what BK wrote above, running QtWeb as root runs fine for me with my own amended preferences in root/QtWebSettings/QtWeb.NET/QtWeb Internet Browser.ini . There is no need to move and rename.


Posted on 22 Jul 2013, 2:23 by Terryphi
Glxgears comparison
Absolutely no difference in glxgears results for me between Precise 5.6.4 and 5.6.9. Both good.


Posted on 22 Jul 2013, 8:43 by BarryK
5.6.9 feedback
If anyone want to provide feedback here, I will read it:

http://www.murga-linux.com/puppy/viewtopic.php?t=87355&start=30



Posted on 22 Jul 2013, 15:20 by Sage
5.6.9
Streets ahead of previous releases - fantastic. Terry is right: no need for regular punters to change anything. QtWeb manages sound, vision, even Flash, so, to state the glaringly obvious, goodbye SM, hello minimalist version!
Folks persisting in bleating about non-root versions with all the latest toys should select one of the majors and go with FULL install - Puppy was/is a different beast for different deploys. Let's keep it that way.


Posted on 22 Jul 2013, 17:06 by Terryphi
Hold on Sage
Sage: look further. QTWeb does not work for live video at BBC News Channel. Presumably there are similar failures elsewhere.


Posted on 22 Jul 2013, 17:13 by aarf
built in feature


Hold on Sage
Sage: look further. QTWeb does not work for live video at BBC News Channel. Presumably there are similar failures elsewhere.
yes thats a new highly requested built in feature, enjoy.


Posted on 22 Jul 2013, 18:08 by Sage
"QTWeb does not work for live video at BBC "
Ha! You may be correct. I have a TV/monitor combo so I simply press a button on the remote for live TV and use iPlayer for stuff I missed during a trip to the local - you know how it is!
Space for some Aussie comments? Please take Mssrs Crosby & Murdoch back - we don't want them over here. On the other hand, we are more than happy with your cricket selections! Anyone for tennis...


Posted on 22 Jul 2013, 18:12 by BarryK
Geany 1.23.1
This pup has Geany version 1.23.1, however, I discovered that colour syntax highlighting of shell scripts is broken.

It should be fixable. Whoever made the changes could be informed.

However, I am taking the easy way out and rolling back to the previous PET, which is 1.19.1 (it is in the 'wary5' repo).



Posted on 22 Jul 2013, 18:17 by BarryK
Precise 5.6.9 feedback
James C has started a Forum thread for feedback:

http://www.murga-linux.com/puppy/viewtopic.php?t=87545



Posted on 22 Jul 2013, 18:29 by BarryK
QtWeb.png
OscarTalks reported in the Forum that the icon /usr/share/pixmaps/qtweb.png would be better off named QtWeb.png.

Yes, I created a symlink in the PET, re-uploading it now, to the 'common' repo at ibiblio.org.



Posted on 22 Jul 2013, 18:39 by BarryK
Pcur cursor themes
bigpup reported in the Forum that Pcur directs to install 'cursor_themes' in the Desktop category in the 'puppy-noarch' repository, in the Puppy Package Manager. But, it isn't there.

Yes it is.

The combobox in the PPM is set to display "GUI apps only".

'cursor_themes' is not strictly a "GUI app". Change the selection to show all apps, or use the search box.



Posted on 22 Jul 2013, 22:40 by Terryphi
BBC News fix
It is possible to get QtWeb working correctly with BBC News Channel Live with the addition of this package via the PPM:

gstreamer0.10-plugins-base_0.10.36


Posted on 22 Jul 2013, 22:58 by Terryphi
BBC News NOT fixed
This is really weird. On subsequently opening QtWeb the above fix does not work and the problem persists.


Posted on 22 Jul 2013, 24:32 by XXX
Thanks
Thanks Barry !!!! You're doing it right !!!


Posted on 24 Jul 2013, 9:21 by scsijon
libevdev 0.2
Just in case you've missed it barry:

Peter Hutterer has just anounced:
[ANNOUNCE] libevdev 0.2

This is the first release for libevdev, a C library that wraps the
kernel evdev interface. The benefits are
* type-safe interface for checking bits on a device
* various abstractions for ioctls that aren't quite as straightforward (e.g.
EV_REP handling)
* simple abstraction for handling SYN_DROPPED events

This library is now hosted on freedesktop.org:
http://www.freedesktop.org/wiki/Software/libevdev/

Future announcements will only go to input-tools@lists.freedesktop.org

regards


Posted on 25 Jul 2013, 3:33 by Sage
BBC News Live
Glad to confirm that BBCNEWS Live works ootb without any additions/changes/links/w.h.y. to the basic 5.6.9 as d/l. No symlinks, updates, no nothink needed!


Posted on 25 Jul 2013, 14:40 by Sage
Live BBC
[i]supra/i] - with QtWeb, that is. Maybe Terry has an HW or ISP issue?


Posted on 25 Jul 2013, 17:39 by BarryK
Precise 5.7beta2 coming
I should be able to upload Precise 5.7beta2 tomorrow night.

A few things to fix first.

Beta2 will have both SeaMonkey and Opera, instead of QtWeb.

The Opera PET is not much bigger than QtWeb, and the live-CD .iso file is still under 200MB.