site  contact  subhomenews

Inkscape 0.91 for April64

April 20, 2015 — BarryK
I have compiled Inkscape 0.91 for the amd64 (x86_64) build of Quirky April. No extra dependencies required, this will work in April64 7.0.3, though the 'devx' PET package is recommended as it has python, needed for many of the Inkscape plugins.

Download (16.7MB):
http://distro.ibiblio.org/quirky/quirky6/amd64/packages/pet_packages-april/inkscape-0.91-amd64.pet

Note, if you don't want to install the 'devx' PET, which is very big, it should be sufficient to install the 'python' package only -- which you can find in the "t2-april" repository in the Package Manager.

I intend to compile for the i686 April soon.

Note, compiling Inkscape required updating of gtkmm, which is required to compile only. This will be in the 'devx' PET of 7.0.4.

Ongoing discussion of all things Quirky is here:
http://murga-linux.com/puppy/viewtopic.php?t=97897&start=480

Comments

I have compiled Inkscape 0.91 in T2, for both amd64 and i686.

You can download the i686 package from here (20.5MB):
http://distro.ibiblio.org/quirky/quirky6/x86/packages/t2/april/inkscape-0.91.tar.bz2

In this case, you will need the dependency 'gsl', as I compiled it in T2 as a shared lib (1.1MB):
http://distro.ibiblio.org/quirky/quirky6/x86/packages/t2/april/gsl-1.16.tar.bz2

One limitation in Quirky right now, is that you can't just click on a .tar.bz2 file to install it -- the Xarchive app opens instead.

However, you can do like this:

# petget `pwd`/inkscape-0.91.tar.bz2

It can also be installed via the Package Manager, which exposes another problem. Missing dependences will show up such as 'gtkmm', but they are not needed. Only 'gsl' is needed.
That is another thing on the to-do list.

Oh yeah, the 't2-april' repo database will have to be updated in the Package Manager, to show the latest pkgs.

Tags: linux