site  contact  subhomenews

Quirky Installer improved

October 07, 2015 — BarryK
Puppy Forum member 'linuxcbon' reported that the Quirky Installer failed to install Quirky 7.2 to a hard drive partition.
He was running Precise Puppy 5.7.1.

Precise Puppy 5.7.1 was released mid-2013, getting a bit long-in-the-tooth by now.

So, my thought was that there is something too-old in it. Yes, I found that the 'cp' utility which is embedded inside Quirky Installer requires a later version of glibc. The other embedded utilities are OK.

I solved the problem by using a statically-compiled 'cp', and installation to a partition now works, running on a host Precise 5.7.1.

The updated installers are here (1.4MB, 1.3MB):
http://distro.ibiblio.org/quirky/quirky6/amd64/releases/april-7.2/installquirky.amd64
http://distro.ibiblio.org/quirky/quirky6/amd64/releases/april-7.2/installquirky.x86

...you will need the second one for Precise 5.7.1, as it is a x86 32-bit OS.

Tags: quirky, linux